• 1048. Find Coins (25)


    1048. Find Coins (25)

    时间限制
    100 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 105 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (<=105, the total number of coins) and M(<=103, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print in one line the two face values V1 and V2 (separated by a space) such that V1 + V2 = M and V1 <= V2. If such a solution is not unique, output the one with the smallest V1. If there is no solution, output "No Solution" instead.

    Sample Input 1:
    8 15
    1 2 8 7 2 4 11 15
    
    Sample Output 1:
    4 11
    
    Sample Input 2:
    7 14
    1 8 7 2 4 11 15
    
    Sample Output 2:
    No Solution
    


    代码:

    #include <iostream>
    #include <algorithm>
    using namespace std;
    
    int main()
    {
        int n,m,flag=0;
        int a[100000];
        cin>>n>>m;
        for(int i=0;i<n;i++)
        {
            cin>>a[i];
            if(a[i]>=m)i--,n--;
        }
        sort(a,a+n);
        for(int i=n-1;i>=0;i--)
        {
            if(a[i]+a[0]>m)n--;
            else break;
        }
        if(a[n-1]+a[n-2]>=m)
        for(int i=0;i<n-1;i++)
        {
            if(a[i]+a[i+1]>m)break;
            else if(a[i]+a[n-1]<m)continue;//加上这一条就不超时了。。
            for(int j=i+1;j<n;j++)
            if(a[i]+a[j]==m)
            {
                cout<<a[i]<<' '<<a[j];
                flag=1;
                break;
            }
            if(flag)break;
        }
        if(flag==0)cout<<"No Solution";
    }
  • 相关阅读:
    Oracle(PLSQL)入门学习五
    visual studio 调试 不进断点 断点失效 提示当前不会命中该断点等问题解决
    java maven项目 导入jar包注意
    sql语句 like 条件查询
    sql语句 查询分组后的每组的第一条或最后一条数据
    文件上传的一些验证(文件类型)
    图片上传回显
    oracle数据库建表设置自增主键
    bootstrap时时提醒填入数据是否与数据库数据重复
    Oracle分析函数列表分享
  • 原文地址:https://www.cnblogs.com/8023spz/p/7299468.html
Copyright © 2020-2023  润新知