• Wireless Network 并查集


    An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

    In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.
    Input
    The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
    1. "O p" (1 <= p <= N), which means repairing computer p.
    2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate.

    The input will not exceed 300000 lines.
    Output
    For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.
    Sample Input
    4 1
    0 1
    0 2
    0 3
    0 4
    O 1
    O 2
    O 4
    S 1 4
    O 3
    S 1 4
    
    Sample Output
    FAIL
    SUCCESS
    

    遇到这种坐标求距离的最好就是输入double精确度高,然后并查集


    代码:

    #include <iostream>
    #include <cstdio>
    #include <cstdlib>
    #include <cstring>
    #include <queue>
    #include <string>
    #include <cmath>
    using namespace std;
    int n,d,p,q;
    char ch;
    int f[1002];
    int stack[1002],head;
    struct loc
    {
        double x,y;
        int id;
    }ro[1002];
    void init()
    {
        for(int i=1;i<=n;i++)
            f[i]=i;
    }
    int getf(int x)
    {
        if(x!=f[x])f[x]=getf(f[x]);
        return f[x];
    }
    int merge(int x,int y)
    {
        int xx=getf(x),yy=getf(y);
        f[yy]=xx;
    }
    void check(int a,int b)
    {
        if(sqrt(pow(ro[a].x-ro[b].x,2)+pow(ro[a].y-ro[b].y,2))<=d)merge(a,b);
    }
    int main()
    {
       scanf("%d %d",&n,&d);
       init();
       for(int i=1;i<=n;i++)
       {
           scanf("%lf%lf",&ro[i].x,&ro[i].y);
       }
    
       while(cin>>ch)
       {
           if(ch=='O')
           {
               scanf("%d",&p);
               stack[head++]=p;
               for(int i=0;i<head-1;i++)
               {
                  check(stack[i],p);
               }
           }
           else
           {
               scanf("%d %d",&p,&q);
               if(getf(p)==getf(q))cout<<"SUCCESS"<<endl;
               else cout<<"FAIL"<<endl;
           }
       }
    }
  • 相关阅读:
    互联网行业进入规范和监管时期 大数据行业也不例外
    R语言与显著性检验学习笔记
    R语言与显著性检验学习笔记
    大数据应用向前一步是什么
    大数据应用向前一步是什么
    CAS 4.0 配置开发手冊
    WinCE隐藏显示任务栏,当任务栏隐藏时将其显示,当任务栏显示时将其隐藏(FindWindow,ShowWindow,IsWindowVisible),
    每日算法之二十六:Substring with Concatenation of All Words
    Django网站管理--ModelAdmin
    Android实战简易教程-第四十一枪(显示倒计时的Button-适用于获取验证码)
  • 原文地址:https://www.cnblogs.com/8023spz/p/7217535.html
Copyright © 2020-2023  润新知