• Windows Message Queue


    Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.


    Input

    There's only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there're one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.

    Output

    For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there's no message in the queue, output "EMPTY QUEUE!". There's no output for "PUT" command.

    Sample Input
    GET
    PUT msg1 10 5
    PUT msg2 10 4
    GET
    GET
    GET
    
    Sample Output
    EMPTY QUEUE!
    msg2 10
    msg1 10
    EMPTY QUEUE!
    

    优先队列。。简单

    #include <iostream>
    #include <cstdio>
    #include <cstdlib>
    #include <cstring>
    #include <queue>
    #include <string>
    
    using namespace std;
    
    struct mes
    {
        string name;
        int par,pri;
        friend bool operator <(mes a,mes b)
        {
            return a.pri>b.pri;
        }
    }temp;
    int main()
    {
       priority_queue<mes>q;
       string ins;
       while(cin>>ins)
       {
           if(ins=="GET")
           {
               if(!q.empty()){cout<<q.top().name<<' '<<q.top().par<<endl;q.pop();}
               else
               {
                   cout<<"EMPTY QUEUE!"<<endl;
               }
           }
           else
           {
               cin>>temp.name>>temp.par>>temp.pri;
               q.push(temp);
           }
       }
    
    }
  • 相关阅读:
    数据库维护单数据修改(入库单月份更改)
    Git下载GitHub上的文件
    水晶报表的步骤
    html表格及列表
    html中的a标签
    了解html标签
    常见编码方式(码表)
    了解html
    Odoo官方翻译网站
    postgresql性能的几个重要参数
  • 原文地址:https://www.cnblogs.com/8023spz/p/7217378.html
Copyright © 2020-2023  润新知