• 7-27 家谱处理 (30分)


    人类学研究对于家族很感兴趣,于是研究人员搜集了一些家族的家谱进行研究。实验中,使用计算机处理家谱。为了实现这个目的,研究人员将家谱转换为文本文件。下面为家谱文本文件的实例:

    John
      Robert
        Frank
        Andrew
      Nancy
        David
    
     

    家谱文本文件中,每一行包含一个人的名字。第一行中的名字是这个家族最早的祖先。家谱仅包含最早祖先的后代,而他们的丈夫或妻子不出现在家谱中。每个人的子女比父母多缩进2个空格。以上述家谱文本文件为例,John这个家族最早的祖先,他有两个子女RobertNancyRobert有两个子女FrankAndrewNancy只有一个子女David

    在实验中,研究人员还收集了家庭文件,并提取了家谱中有关两个人关系的陈述语句。下面为家谱中关系的陈述语句实例:

    John is the parent of Robert
    Robert is a sibling of Nancy
    David is a descendant of Robert
    
     

    研究人员需要判断每个陈述语句是真还是假,请编写程序帮助研究人员判断。

    输入格式:

    输入首先给出2个正整数N(2)和M(≤),其中N为家谱中名字的数量,M为家谱中陈述语句的数量,输入的每行不超过70个字符。

    名字的字符串由不超过10个英文字母组成。在家谱中的第一行给出的名字前没有缩进空格。家谱中的其他名字至少缩进2个空格,即他们是家谱中最早祖先(第一行给出的名字)的后代,且如果家谱中一个名字前缩进k个空格,则下一行中名字至多缩进k+2个空格。

    在一个家谱中同样的名字不会出现两次,且家谱中没有出现的名字不会出现在陈述语句中。每句陈述语句格式如下,其中XY为家谱中的不同名字:

    X is a child of Y
    X is the parent of Y
    X is a sibling of Y
    X is a descendant of Y
    X is an ancestor of Y
    
     

    输出格式:

    对于测试用例中的每句陈述语句,在一行中输出True,如果陈述为真,或False,如果陈述为假。

    输入样例:

    6 5
    John
      Robert
        Frank
        Andrew
      Nancy
        David
    Robert is a child of John
    Robert is an ancestor of Andrew
    Robert is a sibling of Nancy
    Nancy is the parent of Frank
    John is a descendant of Andrew
    
     

    输出样例:

    True
    True
    True
    False
    False

    每次更新第n代的最新人物,方便找到每个人的父代,题目保证两行人要么没明显关系,要么不会差超过一代。

    代码:
    #include <cstdio>
    #include <iostream>
    #include <cstring>
    #include <map>
    using namespace std;
    int n,m,f[101];
    map<string,int> mp;
    char name[11],p1[11],p2[11],r[11],pre[101][11];
    int main() {
        scanf("%d%d",&n,&m);
        getchar();
        for(int i = 0;i < n;i ++) {
            int c = 0,cc = 0;
            while((name[0] = getchar()) == ' ') c ++;
            c /= 2;
            while((name[++ cc] = getchar()) != '
    ');
            name[cc] = 0;
            mp[name] = i + 1;
            if(c) f[i + 1] = mp[pre[c - 1]];
            strcpy(pre[c],name);
        }
        for(int i = 0;i < m;i ++) {
            scanf("%s%s%s%s%s%s",p1,r,r,r,p2,p2);
            if(!strcmp(r,"child")) puts(f[mp[p1]] == mp[p2] ? "True" : "False");
            else if(!strcmp(r,"parent")) puts(f[mp[p2]] == mp[p1] ? "True" : "False");
            else if(!strcmp(r,"sibling")) puts(f[mp[p1]] == f[mp[p2]] ? "True" : "False");
            else if(!strcmp(r,"descendant")) {
                int a = mp[p1],b = mp[p2];
                while(a && a != b) a = f[a];
                puts(a ? "True" : "False");
            }
            else {
                int a = mp[p2],b = mp[p1];
                while(a && a != b) a = f[a];
                puts(a ? "True" : "False");
            }
        }
    }
  • 相关阅读:
    asp.net 微信企业号办公系统-流程设计--流程步骤设置-策略设置
    asp.net 微信企业号办公系统-流程设计--流程步骤设置-基本设置
    asp.net 微信企业号办公系统-流程设计-流程属性设置
    asp.net 微信企业号办公系统-表单设计-保存与发布
    asp.net 微信企业号办公系统-表单设计-数据表格
    asp.net 微信企业号办公系统-表单设计-子表
    asp.net 微信企业号办公系统-表单设计-附件管理
    asp.net 微信企业号办公系统-表单设计-日期时间选择
    asp.net 微信企业号办公系统-表单设计-组织机构选择
    asp.net 微信企业号办公系统-表单设计-数据字典选择
  • 原文地址:https://www.cnblogs.com/8023spz/p/12296330.html
Copyright © 2020-2023  润新知