• 7-16 Sort with Swap(0, i) (25分) 与零交换


    Given any permutation of the numbers {0, 1, 2,..., N1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

    Swap(0, 1) => {4, 1, 2, 0, 3}
    Swap(0, 3) => {4, 1, 2, 3, 0}
    Swap(0, 4) => {0, 1, 2, 3, 4}
    
     

    Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

    Input Specification:

    Each input file contains one test case, which gives a positive N (≤) followed by a permutation sequence of {0, 1, ..., N1}. All the numbers in a line are separated by a space.

    Output Specification:

    For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

    Sample Input:

    10
    3 5 7 2 6 4 9 0 8 1
    
     

    Sample Output:

    9

    能够发现序列是由几个环组成,每个环内的元素排好序就可以使得环内元素在正确的位置上,走一遍样例就可以发现,一个环内的元素相互交换最少需要元素数-1次操作就可以排好序,由于只能和0交换,如果这个环包括0,那就需要交换元素数-1次,否则的话,需要把0交换进环,再交换出去,需要交换元素数-1+2次即元素数+1。如果一个元素本来就在正确位置那就不用交换。
    代码:
    #include <stdio.h>
    #include <stdlib.h>
    
    int main() {
        int n,s[100000],ans = 0;
        scanf("%d",&n);
        for(int i = 0;i < n;i ++) {
            scanf("%d",&s[i]);
        }
        for(int i = 0;i < n;i ++) {
            int k = s[i];
            int c = 0;
            while(s[k] != k) {
                c ++;
                int t = k;
                k = s[k];
                s[t] = t;
            }
            if(c == 0) continue;
            if(i == 0) ans += c - 1;
            else ans += c + 1;
        }
        printf("%d",ans);
    }
  • 相关阅读:
    springboot属性类自动加载配置文件中的值
    mysql修改root密码
    idea各种图标说明
    nginx安装配置
    notepad++下载32位,安装插件管理
    crontab 定时执行脚本出错,但手动执行脚本正常
    jenkins安装配置
    VirtualBox从USB设备(PE)启动图文教程
    如何卸载windows的服务?卸载服务?
    在Windows的CMD中如何设置支持UTF8编码?
  • 原文地址:https://www.cnblogs.com/8023spz/p/12266366.html
Copyright © 2020-2023  润新知