• pat甲级 1155 Heap Paths (30 分)


    In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

    One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

    Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N (1), the number of keys in the tree. Then the next line contains Ndistinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

    Output Specification:

    For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

    Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

    Sample Input 1:

    8
    98 72 86 60 65 12 23 50
    

    Sample Output 1:

    98 86 23
    98 86 12
    98 72 65
    98 72 60 50
    Max Heap
    

    Sample Input 2:

    8
    8 38 25 58 52 82 70 60
    

    Sample Output 2:

    8 25 70
    8 25 82
    8 38 52
    8 38 58 60
    Min Heap
    

    Sample Input 3:

    8
    10 28 15 12 34 9 8 56
    

    Sample Output 3:

    10 15 8
    10 15 9
    10 28 34
    10 28 12 56
    Not Heap

    考察堆的性质,总的来说很简单。
    代码:
    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    #define MAX 1000
    #define DMAX 10000
    using namespace std;
    typedef long long ll;
    int n;
    int big,small;
    int heap[MAX + 1],t[MAX + 1];
    void print(int h) {
        for(int i = 0;i <= h;i ++) {
            printf("%d",t[i]);
            putchar(i < h ? ' ' : '
    ');
        }
    }
    void traversal(int k,int h) {
        if(k > n) {
            return ;
        }
        t[h] = heap[k];
        if(k * 2 > n) print(h);
        if(h) {
            if(t[h] > t[h - 1]) small = 1;
            else if(t[h] < t[h - 1]) big = 1;
        }
        traversal(k * 2 + 1,h + 1);
        traversal(k * 2,h + 1);
    }
    int main() {
        scanf("%d",&n);
        for(int i = 1;i <= n;i ++) {
            scanf("%d",&heap[i]);
        }
        traversal(1,0);
        if(big == small) puts("Not Heap");
        else if(big) puts("Max Heap");
        else puts("Min Heap");
    }
     
  • 相关阅读:
    pyspark读取parquet数据
    python求时间差
    pandas索引操作之loc,iloc,ix等方法
    pandas的concat和drop函数
    mysql语句的书写顺序和执行顺序
    hive的lower,upper,length,concat,lpad,rpad,cast,split函数简述
    hive的floor函数,ceil函数,round函数
    Pandas建立空的dataframe和cumsum累加函数
    Python基础笔记二之求序列均值、标准差、中位数、分位数
    NAT实验
  • 原文地址:https://www.cnblogs.com/8023spz/p/10110647.html
Copyright © 2020-2023  润新知