• ZOJ 1083 Frame Stacking


    Frame Stacking
    Time Limit: 2 Seconds      Memory Limit: 65536 KB
    
    Consider the following 5 picture frames placed on an 9 x 8 array.
    
    Now place them on top of one another starting with 1 at the bottom and ending up with 5 on top. If any part of a frame covers another it hides that part of the frame below.
    
    Viewing the stack of 5 frames we see the following.
    
    In what order are the frames stacked from bottom to top? The answer is EDABC.
    
    Your problem is to determine the order in which the frames are stacked from bottom to top given a picture of the stacked frames. Here are the rules:
    
    1. The width of the frame is always exactly 1 character and the sides are never shorter than 3 characters.
    
    2. It is possible to see at least one part of each of the four sides of a frame. A corner shows two sides.
    
    3. The frames will be lettered with capital letters, and no two frames will be assigned the same letter.
    
    
    INPUT DATA
    
    Each input block contains the height, h (h<=30) on the first line and the width w (w<=30) on the second. A picture of the stacked frames is then given as h strings with w characters each.
    
    
    Example input:
    
    9
    8
    .CCC....
    ECBCBB..
    DCBCDB..
    DCCC.B..
    D.B.ABAA
    D.BBBB.A
    DDDDAD.A
    E...AAAA
    EEEEEE..
    
    Your input may contain multiple blocks of the format described above, without any blank lines in between. All blocks in the input must be processed sequentially.
    
    
    OUTPUT DATA
    
    Write the solution to the standard output. Give the letters of the frames in the order they were stacked from bottom to top. If there are multiple possibilities for an ordering, list all such possibilities in alphabetical order, each one on a separate line. There will always be at least one legal ordering for each input block. List the output for all blocks in the input sequentially, without any blank lines (not even between blocks).
    
    
    Example Output:
    
    EDABC 

    //确定每个图形的4个顶点、然后就可以确定它被几个图覆盖了
    //拓扑排序 至于输出所有情况的话、dfs搞定(不过要按字母序编号噢)
    #include <iostream>
    #include <stdio.h>
    #include <queue>
    #include <stack>
    #include <set>
    #include <vector>
    #include <math.h>
    #include <string.h>
    #include <algorithm>
    using namespace std;
    vector <int> v[28];
    struct ID
    {
        int x,y;
    };
    struct node
    {
        ID lt;
        ID rb;
        char c;
        bool operator <(const node &b) const
        {
            return c<b.c;
        }
    }rc[28];
    bool br[28];
    bool bin[28][28];
    int in[28];
    int id[128];
    char pt[28];
    char map[33][33];
    int k;
    
    void dfs(int dp)
    {
        if(dp==k)
        {
            pt[dp]='\0';
            printf("%s\n",pt);
            return;
        }
        int l,i,j;
        for(i=0;i<k;i++)
         {
            if(br[i]) continue;
            if(in[i]==0)
            {
               pt[dp]=rc[i].c;
               l=v[i].size();
              for(j=0;j<l;j++)
               in[v[i][j]]--;
               br[i]=1;
               dfs(dp+1);
               br[i]=0;
              for(j=0;j<l;j++)
               in[v[i][j]]++;
            }
         }
    }
    int main()
    {
    
        int h,w;
        int i,j;
        while(scanf("%d %d",&h,&w)!=EOF)
        {
            getchar();
            int tp=0;
            memset(br,0,sizeof(br));
            memset(in,0,sizeof(in));
            memset(bin,0,sizeof(bin));
            for(k=i=0;i<h;getchar(),i++)
                for(j=0;j<w;j++)
                   {
                       scanf("%c",&map[i][j]);
                       if(map[i][j]=='.') continue;
                       if(!br[map[i][j]-'A'])
                       {
                           br[map[i][j]-'A']=1;
                           rc[k].c=map[i][j];
                           rc[k].lt.x=i;rc[k].lt.y=j;
                           rc[k].rb.x=i;rc[k].rb.y=j;
                           id[rc[k].c]=k;
                           k++;
                       }
                       else
                       {
                           tp=id[map[i][j]];
                           if(i<rc[tp].lt.x) rc[tp].lt.x=i;
                           if(i>rc[tp].rb.x) rc[tp].rb.x=i;
                           if(j<rc[tp].lt.y) rc[tp].lt.y=j;
                           if(j>rc[tp].rb.y) rc[tp].rb.y=j;
                       }
                   }
           sort(rc,rc+k);
           for(i=0;i<k;i++)
             id[rc[i].c]=i;
          int x,y;
          for(i=0;i<k;i++)
          {
              x=rc[i].lt.x;
             for(y=rc[i].lt.y;y<=rc[i].rb.y;y++)
               if(map[x][y]!=rc[i].c)
               {
                   tp=id[map[x][y]];
                   if(bin[i][tp]) continue;
                   v[i].push_back(tp);
                   in[tp]++;
                   bin[i][tp]=1;
               }
              x=rc[i].rb.x;
             for(y=rc[i].lt.y;y<=rc[i].rb.y;y++)
               if(map[x][y]!=rc[i].c)
               {
                   tp=id[map[x][y]];
                   if(bin[i][tp]) continue;
                   v[i].push_back(tp);
                   in[tp]++;
                   bin[i][tp]=1;
               }
             y=rc[i].lt.y;
             for(x=rc[i].lt.x;x<=rc[i].rb.x;x++)
               if(map[x][y]!=rc[i].c)
               {
                    tp=id[map[x][y]];
                   if(bin[i][tp]) continue;
                   v[i].push_back(tp);
                   in[tp]++;
                   bin[i][tp]=1;
               }
             y=rc[i].rb.y;
             for(x=rc[i].lt.x;x<=rc[i].rb.x;x++)
               if(map[x][y]!=rc[i].c)
               {
                   tp=id[map[x][y]];
                   if(bin[i][tp]) continue;
                   v[i].push_back(tp);
                   in[tp]++;
                   bin[i][tp]=1;
               }
          }
          memset(br,0,sizeof(br));
          dfs(0);
          for(i=0;i<k;i++) v[i].clear();
        }
        return 0;
    }
     
  • 相关阅读:
    复习静态页面polo-360
    fsm三种建模思路比较
    web前端学习(一) j2ee环境搭配+jsp中的编码问题
    git与github建立链接(学习笔记)
    g++编译多个源原文件和头文件(转载)
    百度搜索引擎设置
    Google自带截图工具的使用
    git与github建立链接(将本次项目与网络GitHub同步) --转存笔记
    初识JQuery(1)-选择器
    同步与异步的区别
  • 原文地址:https://www.cnblogs.com/372465774y/p/2766285.html
Copyright © 2020-2023  润新知