• ZOJ Problem Set 1879


    ZOJ Problem Set - 1879
    Jolly Jumpers

    Time Limit: 2 Seconds      Memory Limit: 65536 KB

    A sequence of n > 0 integers is called a jolly jumper if the absolute values of the difference between successive elements take on all the values 1 through n-1. For instance,

    1 4 2 3

    is a jolly jumper, because the absolutes differences are 3, 2, and 1 respectively. The definition implies that any sequence of a single integer is a jolly jumper. You are to write a program to determine whether or not each of a number of sequences is a jolly jumper.


    Input

    Each line of input contains an integer n < 3000 followed by n integers representing the sequence.


    Output

    For each line of input, generate a line of output saying "Jolly" or "Not jolly".


    Sample Input

    4 1 4 2 3
    5 1 4 2 -1 6


    Sample Output

    Jolly
    Not jolly


    Source: University of Waterloo Local Contest 2000.09.30

    //简单模拟题

    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    #include <algorithm>
    #include <queue>
    using namespace std;
    bool hash[3002];
    int a[3002];
    int main()
    {
        int n,i;
        bool f;
        while(scanf("%d",&n)!=EOF)
        {
            for(i=1;i<=n;i++)
             scanf("%d",&a[i]),hash[i]=0;
            for(f=1,i=2;i<n;i++)
            {
                if(a[i]>a[i-1])
                {
                    if(a[i]-a[i-1]>=n||a[i]-a[i-1]<1)
                       {
                           f=0;break;
                       }
                   if(!hash[a[i]-a[i-1]])
                     hash[a[i]-a[i-1]]=1;
                    else
                    {
                        f=0;break;
                    }
                }
                else
                {
                   if(a[i-1]-a[i]>=n||a[i-1]-a[i]<1)
                       {
                           f=0;break;
                       }
                   if(!hash[a[i-1]-a[i]])
                     hash[a[i-1]-a[i]]=1;
                    else
                    {
                        f=0;break;
                    }
                }
            }
            if(f) printf("Jolly\n");
            else printf("Not jolly\n");
        }
        return 0;
    }

  • 相关阅读:
    Mongodb启动命令mongod参数说明
    10款免费且开源的项目管理工具
    如何让ConfigurationManager打开任意的配置文件
    Sql Server FOR XML PATH
    常用项目管理工具
    ThinkPHP最新版本SQL注入漏洞
    支付宝内部人士是这样设密码的!太牛逼了!
    犯罪分子如何用身份证套你的钱
    解析漏洞总结
    Sqlserver2008+搜索型注入技术
  • 原文地址:https://www.cnblogs.com/372465774y/p/2618411.html
Copyright © 2020-2023  润新知