• hdu 1385 ZOJ 1456 Minimum Transport Cost(经典floyd)


    Minimum Transport Cost

    Time Limit: 2 Seconds      Memory Limit: 65536 KB

    These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts:

    The cost of the transportation on the path between these cities, and

    a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

    You must write a program to find the route which has the minimum cost.


    Input

    First is N, number of cities. N = 0 indicates the end of input.

    The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

    a11 a12 ... a1N
    a21 a22 ... a2N
    ...............
    aN1 aN2 ... aNN
    b1  b2  ... bN

    c d
    e f
    ...
    g h

    where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:


    Output

    From c to d :
    Path: c-->c1-->......-->ck-->d
    Total cost : ......
    ......

    From e to f :
    Path: e-->e1-->..........-->ek-->f
    Total cost : ......

    Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.


    Sample Input

    5
    0 3 22 -1 4
    3 0 5 -1 -1
    22 5 0 9 20
    -1 -1 9 0 4
    4 -1 20 4 0
    5 17 8 3 1
    1 3
    3 5
    2 4
    -1 -1
    0


    Sample Output

    From 1 to 3 :
    Path: 1-->5-->4-->3
    Total cost : 21

    From 3 to 5 :
    Path: 3-->4-->5
    Total cost : 16

    From 2 to 4 :
    Path: 2-->1-->5-->4
    Total cost : 17

    http://acm.hdu.edu.cn/showproblem.php?pid=1385

    //以前不知道在使用floyd算法和并打印路径

    //学了这题的做法后,知道勒 p[i][j]可以有2中含义、含义不同存储的东西就不同了

    //1.代表从i到j的最短路中 j的前驱

    //2.代表从i到j的最短路中i的后继

    //这题不仅边上带有权值、点上也带权值,因为本题打印需要,选择第2种路径保存方法

    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    #include <algorithm>
    #define N 133
    #define inf 100000000
    using namespace std;
    int a[N][N],p[N][N],b[N];
    int road[N];
    int main()
    {
        int n;
        int i,j,k,t;
        int from,to;
        while(scanf("%d",&n),n)
        {
            for(i=1;i<=n;i++)
              for(j=1;j<=n;j++)
                 {
                     scanf("%d",&a[i][j]);
                     if(a[i][j]==-1) a[i][j]=inf;
                      p[i][j]=j;
                 }

            for(i=1;i<=n;i++)
              scanf("%d",&b[i]);

            for(k=1;k<=n;k++)
              for(i=1;i<=n;i++)
                for(j=1;j<=n;j++)
               if(a[i][j]>a[i][k]+a[k][j]+b[k])
                   {
                       a[i][j]=a[i][k]+a[k][j]+b[k];
                       p[i][j]=p[i][k];
                   }
                   else if(a[i][j]==a[i][k]+a[k][j]+b[k])
                        {
                            if(p[i][j]>p[i][k])
                              p[i][j]=p[i][k];
                        }
            while(scanf("%d%d",&from,&to),from!=-1&&to!=-1)
            {
                printf("From %d to %d :\n",from,to);
                printf("Path: %d",from);
                for(t=from;t!=to;t=p[t][to]) printf("-->%d",p[t][to]);
                printf("\nTotal cost : %d\n\n",a[from][to]);

            }

        }
        return 0;
    }

  • 相关阅读:
    11-15SQLserver基础--数据库之范式理论
    11-13SQLserver基础--数据库之事务
    11-11SQLserver基础--数据库之触发器
    C#中abstract和virtual区别
    virtual修饰符
    override 修饰符
    访问public
    访问修饰符protected
    访问修饰符private
    访问修饰符internal
  • 原文地址:https://www.cnblogs.com/372465774y/p/2610211.html
Copyright © 2020-2023  润新知