• HDU 1496 Equations


    Equations

    Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 2879    Accepted Submission(s): 1114


    Problem Description
    Consider equations having the following form:

    a*x1^2+b*x2^2+c*x3^2+d*x4^2=0
    a, b, c, d are integers from the interval [-50,50] and any of them cannot be 0.

    It is consider a solution a system ( x1,x2,x3,x4 ) that verifies the equation, xi is an integer from [-100,100] and xi != 0, any i ∈{1,2,3,4}.

    Determine how many solutions satisfy the given equation.
     
    Input
    The input consists of several test cases. Each test case consists of a single line containing the 4 coefficients a, b, c, d, separated by one or more blanks.
    End of file.
     
    Output
    For each test case, output a single line containing the number of the solutions.
     
    Sample Input
    1 2 3 -4 1 1 1 1
     
    Sample Output
    39088 0
     
    Author
    LL
     
    Source
     
    Recommend
    LL

    //有时感觉自己就是个水货、自己坑自己

    //算是hash的简单应用吧

    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    using namespace std;
    int h[103];
    bool f[10003];
    int main()
    {
        int a,b,c,d;
        int i,j,k,temp,t;
        for(i=1;i<=100;i++)
          h[i]=i*i,f[i*i]=1;
        while(scanf("%d%d%d%d",&a,&b,&c,&d)!=EOF)
        {
            if(a>0&&b>0&&c>0&&d>0) { printf("0\n");continue;}
            if(a<0&&b<0&&c<0&&d<0) { printf("0\n");continue;}
            if(a==0||b==0||c==0||d==0) { printf("0\n");continue;}
            int n=0;
            for(i=1;i<=100;i++)
              for(j=1;j<=100;j++)
                for(k=1;k<=100;k++)
                  {
                       temp=a*h[i]+b*h[j]+c*h[k];
                       t=d;
                       if((temp>0&&t>0)||(temp<0&&t<0)) continue;
                       if(temp==0) continue;
                       if(temp<0) temp=-temp;
                       if(t<0) t=-t;
                       if(temp%t!=0) continue;
                       temp=temp/t;
                       if(temp>10000||!f[temp]) continue;
                       n++;
                  }
            printf("%d\n",n*16);//自己很2的写个“n=”在输出里、还一直不明白为啥WA了、看到有这想抽自己的冲动

         //n*16 原因是现在求出来的都是正解,每个x都有正负2种情况 就是2^4=16咯,自己都差点忘记了
        }
        return 0;
    }

  • 相关阅读:
    poi生成excel整理(设置边框/字体/颜色/加粗/居中/)
    java里poi操作Excel工具类【我改】
    java里poi操作excel的工具类(兼容各版本)
    在java poi导入Excel通用工具类示例详解
    layui给select下拉框赋值
    Unity3d开发wp8问题汇总
    Unity3D WP8发布解决方案名 DefaultPackageName 修改问题
    微软发布WP SDK8.0 新增语音、应用内支付等原生API
    unity3d android互调
    解决unity3d发布的网页游戏放到服务器上无法使用的问题
  • 原文地址:https://www.cnblogs.com/372465774y/p/2590192.html
Copyright © 2020-2023  润新知