• POJ 1703 Find them, Catch them


    Find them, Catch them
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 21108   Accepted: 6259

    Description

    The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

    Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

    1. D [a] [b]
    where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

    2. A [a] [b]
    where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.

    Input

    The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

    Output

    For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

    Sample Input

    1
    5 5
    A 1 2
    D 1 2
    A 1 2
    D 2 4
    A 1 4
    

    Sample Output

    Not sure yet.
    In different gangs.
    In the same gang.
    

    Source

    //有了食物链那题的基础、这题就思路清晰了

    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    #include <algorithm>
    #define Y 100003
    using namespace std;
    int f[Y],r[Y];
    bool p[Y];
    int Find(int x)
    {
        if(x!=f[x])
        {
            int tf=f[x];
            f[x]=Find(f[x]);
            p[x]=!(p[x]^p[tf]);//压缩路径的规律
            return f[x];
        }
        return x;
    }
    void union_set(int x,int y)
    {
        int rx=Find(x),ry=Find(y);
        if(r[rx]>r[ry])
         {
             f[ry]=rx;
             p[ry]=(p[x]+p[y])%2;//合并的规律
         }
         else if(r[rx]<r[ry])
              {
                  f[rx]=ry;
                  p[rx]=(p[x]+p[y])%2;
              }
              else
              {   f[ry]=rx;r[rx]++;
                  p[ry]=(p[x]+p[y])%2;
              }
    }
    int main()
    {
        int T;
        int N,M;
        char c;
        int x,y,r1,r2;
        scanf("%d",&T);
        while(T--)
        {
            scanf("%d%d",&N,&M);
            for(int i=1;i<=N;i++)
               f[i]=i,r[i]=p[i]=1;
            while(M--)
            {
                getchar();
                scanf("%c",&c);
                scanf("%d%d",&x,&y);
                if(N==2&&c=='A'&&x!=y)//特殊情况 2个人 A 1 2是可以确定的
                {
                    printf("In different gangs.\n");continue;
                }
                if(c=='D')
                  union_set(x,y);
                else
                 {
                      r1=Find(x);
                      r2=Find(y);
                     if(r1!=r2)
                       printf("Not sure yet.\n");
                     else
                     {
                         if(p[x]==p[y])
                           printf("In the same gang.\n");
                        else
                           printf("In different gangs.\n");//到这我不得不说句:你妹的!!!,少写了个s,WA了几次,晕
                     }
                 }
            }
        }
        return 0;
    }

  • 相关阅读:
    前端笔记之React(五)Redux深入浅出
    前端笔记之React(四)生命周期&Virtual DOM和Diff算法&日历组件开发
    前端笔记之React(三)使用动态样式表&antd&React脚手架&props实战
    前端笔记之React(二)组件内部State&React实战&表单元素的受控
    前端笔记之React(一)初识React&组件&JSX语法
    详解Asp.net MVC DropDownLists
    String.Format格式说明
    jquery日历datepicker的使用方法
    asp.net文本编辑器(FCKeditor)
    将jira添加至开机自启动
  • 原文地址:https://www.cnblogs.com/372465774y/p/2588757.html
Copyright © 2020-2023  润新知