• POJ 1363 Rails


    Rails
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 18531   Accepted: 7391

    Description

    There is a famous railway station in PopPush City. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish only a surface track. Moreover, it turned out that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track.

    The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has N <= 1000 coaches numbered in increasing order 1, 2, ..., N. The chief for train reorganizations must know whether it is possible to marshal coaches continuing in the direction B so that their order will be a1, a2, ..., aN. Help him and write a program that decides whether it is possible to get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at any time there can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station.

    Input

    The input consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integer N described above. In each of the next lines of the block there is a permutation of 1, 2, ..., N. The last line of the block contains just 0.

    The last block consists of just one line containing 0.

    Output

    The output contains the lines corresponding to the lines with permutations in the input. A line of the output contains Yes if it is possible to marshal the coaches in the order required on the corresponding line of the input. Otherwise it contains No. In addition, there is one empty line after the lines corresponding to one block of the input. There is no line in the output corresponding to the last ``null'' block of the input.

    Sample Input

    5
    1 2 3 4 5
    5 4 1 2 3
    0
    6
    6 5 4 3 2 1
    0
    0

    Sample Output

    Yes
    No
    
    Yes
    

    Source

    //这么晚写代码、写的比较乱、思路有些模糊呀、呵呵、栈的简单应用

    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    #include <queue>
    #include <stack>
    #include <vector>
    #include <algorithm>
    using namespace std;
    int main()
    {
        int n,k,i,t;
        while(scanf("%d",&n),n)
        {
            while(scanf("%d",&t),t)
            {
                stack<int> S;
                k=1;
                S.push(k);
               while(S.top()!=t)
                {   k++;
                   S.push(k);
                }
                S.pop();
               for(i=1;i<n;i++)
               {
                  scanf("%d",&t);
                  if(S.empty()) k++,S.push(k);
                  while(S.top()!=t)
                  {  k++;
                    if(k<=n)
                      S.push(k);
                    else
                      break;
                  }
                  if(k<=n)
                    S.pop();
               }
               if(!S.empty())
                 printf("No\n");
                else
                 printf("Yes\n");
            }
           printf("\n");
        }
        return 0;
    }

  • 相关阅读:
    HTTP协议 学习笔记一
    web发展历史
    Easydarwin加FFMPEG实现HLS流视频点播
    C# Socket异步实现消息发送--附带源码
    C# Activex调用USB摄像头--附带源码
    C# listbox DataSource数据绑定--一年半以前的bug
    ASP.NET MVC WebAPI实现文件批量上传
    ASP.NET MVC使用SignalR统计在线用户人数
    Chart.js Y轴数据以百分比展示
    Java获取字符串信息
  • 原文地址:https://www.cnblogs.com/372465774y/p/2583913.html
Copyright © 2020-2023  润新知