• HDU 1301 Jungle Roads



    The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.

    The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.

    The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.
     
    Sample Input
    9 A 2 B 12 I 25 B 3 C 10 H 40 I 8 C 2 D 18 G 55 D 1 E 44 E 2 F 60 G 38 F 0 G 1 H 35 H 1 I 35 3 A 2 B 10 C 40 B 1 C 20 0
     
    Sample Output
    216 30
     
    Source
     
    #include <iostream>
    #include <cstdio>
    #include <cmath>
    #include <string.h>
    using namespace std;
    int
    main()
    {

        int
    i,j,k[33][33],f[133];
        int
    n,b[33],m,l,d;
        char
    s,c;
        for
    (i='A';i<='Z';i++)
          f[i]=i-'A';
        while
    (scanf("%d",&n),n)
        {
      for(i=0;i<n;i++)
            for
    (j=0;j<n;j++)
              k[i][j]=0xfffffff;
             memset(b,0,sizeof(b));
           getchar();l=0;
            for
    (i=1;i<n;i++)
            {

               scanf("%c%d",&s,&m);getchar();
               while
    (m--)
               {

                 scanf("%c%d",&c,&d);getchar();
                  k[f[s]][f[c]]=d;
                  k[f[c]][f[s]]=d;
               }
            }

          b[0]=1;d=n-1;l=0;
          while
    (d--)
          {

              m=0xffffff;
              for
    (i=1;i<n;i++)
                if
    (!b[i]&&k[0][i]<m)
                {

                    m=k[0][i];
                    j=i;
                }

              b[j]=1;
              l+=m;
              for
    (i=1;i<n;i++)
                if
    (!b[i]&&k[j][i]<k[0][i])
                   k[0][i]=k[j][i];

          }

          printf("%d\n",l);

        }

        return
    0;
    }
  • 相关阅读:
    [转] Chrome
    阿里安全潘多拉实验室首先完美越狱苹果iOS 11.2
    【阿里聚安全·安全周刊】阿里双11技术十二讲直播预约|AWS S3配置错误曝光NSA陆军机密文件
    卡巴斯基发布安全公告:2018年威胁预测
    【阿里聚安全·安全周刊】双十一背后的“霸下-七层流量清洗”系统| 大疆 VS “白帽子”,到底谁威胁了谁?
    分享一个白帽交流灵感的社区——先知技术安全社区
    WiFi网络WPA2 KRACK漏洞分析报告
    #云栖大会# 移动安全专场——APP渠道推广作弊攻防那些事儿(演讲速记)
    #云栖大会# 移动安全专场——APP加固新方向(演讲速记)
    Java安全编码:糟糕的在线建议和令人困惑的APIs
  • 原文地址:https://www.cnblogs.com/372465774y/p/2431408.html
Copyright © 2020-2023  润新知