• HDU 1045 Fire Net(DFS)


    Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall. 

    A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening. 

    Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets. 

    The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through. 

    The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways. 



    Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration. 
     
    
    
    Input
    The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file. 
     
    
    
    Output
    For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.
     
    
    
    Sample Input
    
    
    4 .X.. .... XX.. .... 2 XX .X 3 .X. X.X .X. 3 ... .XX .XX 4 .... .... .... .... 0
     
    
    
    Sample Output
    
    
    5 1 5 2 4
    
    
    #include <stdio.h> 
    #include <stdlib.h> 
    #include <string.h> 
    char map[4][4];
     int n,num;
     int jg(int x,int y)//这里是判断该点是否可以放置碉堡
     { int i; for(i=x-1;i>=0;i--) 
    { if(map[i][y]=='f')
     return 0; if(map[i][y]=='X') 
    break; } for(i=y-1;i>=0;i--) 
    { if(map[x][i]=='f') 
    return 0;
    if(map[x][i]=='X') break; 
    } return 1; 
    }
     void search(int i,int t) 
    { 
    int j; for(j=i;j<n*n;j++) //这里算是小小的优化吧
     if(map[j/n][j%n]!='X')
    break; 
    if(j>=n*n) 
    {
     if(t>num)//求出最大值 
    num=t; 
    return;
     } 
    if(jg(j/n,j%n))
     { 
    map[j/n][j%n]='f';
     search(j+1,t+1);
     map[j/n][j%n]='.'; 
    }search(j+1,t);//这点不能丢,不然可能只求了一种情况,值得思考 
    } 
    int main() 
    { int i,j; 
    while(scanf("%d",&n),n) 
    { getchar();
    for(i=0;i<n;getchar(),i++)
     for(j=0;j<n;j++) 
    scanf("%c",&map[i][j]); 
    num=0; 
    search(0,0); 
    printf("%d\n",num);
     }
     return 0;
     }
    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    #include <algorithm>
    #include <queue>
    #include <cmath>
    using namespace std;
    int n,Max;
    char map[6][6];
    bool is(int &x,int &y)
    {
        if(map[x][y]!='.')
         return false;
         int i;
        for(i=x-1;i>=0;i--)
        if(map[i][y]=='X')
           break;
        else if(map[i][y]=='A')
          return false;
        for(i=y-1;i>=0;i--)
        if(map[x][i]=='X') break;
         else if(map[x][i]=='A')
          return false;
        return true;
    }
    void dfs(int k,int cnt)
    {
        if(k>=n*n)
        {
            Max=max(cnt,Max);
            return ;
        }
        int x=k/n,y=k%n;
        if(is(x,y))
        {
            map[x][y]='A';
            dfs(k+1,cnt+1);
            map[x][y]='.';
        }
        dfs(k+1,cnt);
    }
    int main()
    {
      int i;
      while(scanf("%d",&n),n)
      {
          for(i=0;i<n;i++)
           scanf("%s",map[i]);
          Max=0;
          dfs(0,0);
          printf("%d\n",Max);
      }
      return 0;
    }
    
    
    
     
                                                                      --------江财小子
  • 相关阅读:
    每位设计师都应该拥有的50个CSS代码片段-1
    JS OO库的选择
    Dean Edwards -- Base.js(译)
    Jquery中find、filter等几种用法的差异
    深入Java虚拟机读书笔记第三章安全
    深入Java虚拟机读书笔记第二章平台无关性
    深入Java虚拟机读书笔记第一章Java体系结构介绍
    ThinkInJava4读书笔记之第七章隐藏实施过程
    Java反射机制(转载)
    linux常用svn命令(转载)
  • 原文地址:https://www.cnblogs.com/372465774y/p/2421679.html
Copyright © 2020-2023  润新知