• 04-树6 Complete Binary Search Tree (30 分)


    A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

    • The left subtree of a node contains only nodes with keys less than the node's key.
    • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
    • Both the left and right subtrees must also be binary search trees.

      A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

      Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

      Input Specification:

      Each input file contains one test case. For each case, the first line contains a positive integer N (≤). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

      Output Specification:

      For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

      Sample Input:

      10
      1 2 3 4 5 6 7 8 9 0
      

      Sample Output:

      6 3 8 1 5 7 9 0 2 4

    一、题目要求将输入的值用中序遍历然后在用层序遍历输出,所以中序遍历只需要先排列,然后找到最中间的值就行。加上完全树的特性,如果根为0,节点i,左边的儿子是2*i+1,右边的儿子2*i+2。将其排序好后,用数组和层序遍历将其储存和排列最后输出。

    二、代码

    #include<stdio.h>
    #include<stdlib.h>
    #include<math.h>
    #define MAX 1005
    int N, n[MAX], ins[MAX], k = 0;
    int cmp(const int *a, const int *b)
    {
        return *a - *b;
    }
    void inorder(int root);
    int main()
    {
        int i;
        scanf("%d", &N);
        for (i = 0; i < N; i++) scanf("%d", &n[i]);
        qsort(n, N, sizeof(int), cmp);
        inorder(0);
        printf("%d", ins[0]);
        for (i = 1; i < N; i++) printf(" %d", ins[i]);
    }
    void inorder(int root)
    {
        if (root >= N) return;
        inorder(2 * root+1);
        ins[root] = n[k++];
        inorder(2 * root + 2);
    }

    本文参考了:https://blog.csdn.net/qq_36888550/article/details/87929937

          https://blog.csdn.net/ryo_218/article/details/81462130

    感悟:感觉自己连小白都算不上,小白都比我强

  • 相关阅读:
    master线程的主循环,后台循环,刷新循环,暂停循环
    InnoDB的后台线程(IO线程,master线程,锁监控线程,错误监控线程)和内存(缓冲池,重做日志缓冲池,额外内存池)
    MySQL的连接方式
    编写高质量的 Java 代码
    TProfiler
    Copy-On-Write容器
    G1 垃圾收集器
    JAVA 虚拟机钩子
    Future和Promise
    算法笔记_134:字符串编辑距离(Java)
  • 原文地址:https://www.cnblogs.com/2293002826PYozo/p/11301476.html
Copyright © 2020-2023  润新知