• pat1007


    1007. Maximum Subsequence Sum (25)

    时间限制
    400 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

    Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

    Input Specification:

    Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

    Output Specification:

    For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

    Sample Input:
    10
    -10 1 2 3 4 -5 -23 3 7 -21
    
    Sample Output:
    10 1 4
    

    提交代码

    求最长子段和。

    误解题意。。哇了5次。。输出的是从x到y。并不是位子。而是值。

    #include<iostream>
    #include<vector>
    #include<cstdio>
    #include<string.h>
    #include<string>
    #include<algorithm>
    using namespace std;
    
    int main()
    {
    
      int n;
      cin>>n;
      int a[10000];
      int flag=0;
      for(int i=0;i<n;i++)
      {
          cin>>a[i];
          if(a[i]<0)
            flag++;
      }
      int qishi=0;
      int  zhongdian =0;
       int sum = 0,b = 0;
       int qi[10000];
       qi[0]=a[0];
        for(int i = 0;i < n;i ++)
        {
            if(b > 0)
               {
                 b += a[i];
                 qi[i]=qi[i-1];
               }
            else
                {
                    b = a[i];
                    qi[i]=a[i];
    
                }
            if(b > sum)
                {
                    sum = b;
                    qishi=qi[i];
                    zhongdian=a[i];
    
                }
                if(flag==n)
                {
                    sum=0;
                    qishi=a[0];
                    zhongdian=a[n-1];
                }
    
        }
      cout<<sum<<" "<<qishi<<" "<<zhongdian<<endl;
        return 0;
    }
  • 相关阅读:
    使用Razor视图引擎来生成邮件内容
    Asp .Net Core 2.0 登录授权以及多用户登录
    简单几步,提升.Net Core的开发效率
    百万数据测试 Entity Framework 到底有多慢
    纸壳CMS(ZKEACMS)体验升级,快速创建页面,直接在页面中修改内容
    ZKEACMS 配置使用 HTTPS
    使用 jQuery.Pin 垂直滚动时固定导航
    底层的增删查改
    关于hangfire的使用
    巧用 CSS 实现酷炫的充电动画
  • 原文地址:https://www.cnblogs.com/2014slx/p/7800152.html
Copyright © 2020-2023  润新知