• pat1006


    1006. Sign In and Sign Out (25)

    时间限制
    400 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

    Input Specification:

    Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

    ID_number Sign_in_time Sign_out_time
    

    where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

    Output Specification:

    For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

    Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

    Sample Input:
    3
    CS301111 15:30:28 17:00:10
    SC3021234 08:00:00 11:25:25
    CS301133 21:45:00 21:58:40
    
    Sample Output:
    SC3021234 CS301133
    

     输出最早来的人和最晚走的人

    自己写sort函数。

    #include<iostream>
    #include<vector>
    #include<cstdio>
    #include<string.h>
    #include<string>
    #include<algorithm>
    using namespace std;
    struct node
    {
        string a;
        int b,d,f;
        char c,e;
        int b1,d1,f1;
        char c1,e1;
    
    }ren[1000];
    bool cmp1(node q,node w)
    {
        if(q.b==w.b&&q.d==w.d)
            return q.f<w.f;
        if(q.b==w.b)
            return q.d<w.d;
        return q.b<w.b;
    }
    bool cmp2(node q,node w)
    {
        if(q.b1==w.b1&&q.d1==w.d1)
            return q.f1>w.f1;
        if(q.b1==w.b1)
            return q.d1>w.d1;
        return q.b1>w.b1;
    }
    int main()
    {
       int m;
       cin>>m;
       for(int i=0;i<m;i++)
       {
           cin>>ren[i].a;
           cin>>ren[i].b>>ren[i].c>>ren[i].d>>ren[i].e>>ren[i].f;
           cin>>ren[i].b1>>ren[i].c1>>ren[i].d1>>ren[i].e1>>ren[i].f1;
       }
       sort(ren,ren+m,cmp1);
          cout<<ren[0].a;
          sort(ren,ren+m,cmp2);
          cout<<" "<<ren[0].a<<endl;
    
    
        return 0;
    }
  • 相关阅读:
    qs.parse()、qs.stringify() 、JSON.stringify()以及JSON.parse()的区别
    Vue设置button的disable属性
    vue-preview用法详解
    解决MUI不支持js严格模式环境下使用的问题
    Vue.js的keep-alive用法
    详解在webpack中使用axios
    详解VS2012发布web api流程
    解决Python2中文ascii编码的方法
    防火墙问题 Linux系统 /etc/sysconfig/路径下无iptables文件
    本机连接虚拟机中docker启动的mysql数据库
  • 原文地址:https://www.cnblogs.com/2014slx/p/7800126.html
Copyright © 2020-2023  润新知