• Farm Irrigation(非常有意思的并查集)


    Farm Irrigation

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
    Total Submission(s) : 46   Accepted Submission(s) : 26

    Font: Times New Roman | Verdana | Georgia

    Font Size: ← →

    Problem Description

    Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows.


    Figure 1


    Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map 

    ADC
    FJK
    IHE

    then the water pipes are distributed like 


    Figure 2


    Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn. 

    Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him? 

    Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.

    Input

    There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of 'A' to 'K', denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50.

    Output

    For each test case, output in one line the least number of wellsprings needed.

    Sample Input

    2 2
    DK
    HF
    
    3 3
    ADC
    FJK
    IHE
    
    -1 -1
    

    Sample Output

    2
    3
    

    Author

    ZHENG, Lu

    Source

    Zhejiang University Local Contest 2005
    看这这几张图有点懵,其实只要仔细看,也没有很难。因为他的连通就是一个十字形。分成I和一考虑
    与上面有联系的是 ABEGHJK(及下面出头)
    与下面有联系的是CDEHIJK
     
     
    与左边有联系的是 ACFGHIK
    与右边有联系的是BDFGIJK
    #include <iostream>
    
    using namespace std;
    char map[100][100];
    int par[100000];
    int find(int x)
    {
    while(x!=par[x])
    x=par[x];
    return x;
    }
    void unioni(int x,int y)
    {
    int xx=find(x);
    int yy=find(y);
    if(xx!=yy)
    {
    par[yy]=xx;
    }
    
    }
    int main()
    {
    int n,m;
    while(cin>>n>>m)
    {
    if(n<0||m<0)
    break;
    for(int i=0;i<n*m;i++)
    par[i]=i;
    for(int i=0;i<n;i++)
    for(int j=0;j<m;j++)
    {
    cin>>map[i][j];
    }
    
    for(int i=0;i<n;i++)
    for(int j=0;j<m;j++)
    {
    if(i>=1&&(map[i][j]=='A'||map[i][j]=='B'||map[i][j]=='E'||map[i][j]=='G'||map[i][j]=='H'||map[i][j]=='J'||map[i][j]=='K'))
    {
    if(map[i-1][j]=='C'||map[i-1][j]=='D'||map[i-1][j]=='E'||map[i-1][j]=='H'||map[i-1][j]=='I'||map[i-1][j]=='J'||map[i-1][j]=='K')
    {
    unioni((i-1)*m+j,i*m+j);
    }
    }
    if(j>=1&&(map[i][j]=='A'||map[i][j]=='C'||map[i][j]=='F'||map[i][j]=='G'||map[i][j]=='H'||map[i][j]=='I'||map[i][j]=='K'))
    if(map[i][j-1]=='B'||map[i][j-1]=='D'||map[i][j-1]=='F'||map[i][j-1]=='G'||map[i][j-1]=='I'||map[i][j-1]=='J'||map[i][j-1]=='K')
    {
    unioni(i*m+j-1,i*m+j);
    }
    }
    int flag=0;
    for(int i=0;i<n*m;i++)
    {
    if(par[i]==i)
    flag++;
    
    
    }
    cout<<flag<<endl;
    
    }
    return 0;
    }
  • 相关阅读:
    linux使用docker-compose部署软件配置
    Linux CentOS Python开发环境搭建教程
    Linux使用scp命令进行文件远程拷贝详解
    浅析Vue.js 中的条件渲染指令
    浅谈Vue响应式(数组变异方法)
    Laravel框架定时任务2种实现方式示例
    Docker 运行时的用户与组管理的方法
    laravel5实现微信第三方登录功能
    Linux服务器间文件实时同步的实现
    从零开始搭建vue移动端项目到上线的步骤
  • 原文地址:https://www.cnblogs.com/2014slx/p/7216606.html
Copyright © 2020-2023  润新知