• zju 1241 Geometry Made Simple


    Geometry Made Simple

    Time Limit: 2 Seconds      Memory Limit: 65536 KB

    Mathematics can be so easy when you have a computer. Consider the following example. You probably know that in a right-angled triangle, the length of the three sides a, b, c (where c is the longest side, called the hypotenuse) satisfy the relation a*a+b*b=c*c. This is called Pythagora's Law.

    Here we consider the problem of computing the length of the third side, if two are given.

    Input

    The input contains the descriptions of several triangles. Each description consists of a line containing three integers a, b and c, giving the lengths of the respective sides of a right-angled triangle. Exactly one of the three numbers is equal to -1 (the 'unknown' side), the others are positive (the 'given' sides).

    A description having a=b=c=0 terminates the input.


    Output

    For each triangle description in the input, first output the number of the triangle, as shown in the sample output. Then print "Impossible." if there is no right-angled triangle, that has the 'given' side lengths. Otherwise output the length of the 'unknown' side in the format "s = l", where s is the name of the unknown side (a, b or c), and l is its length. l must be printed exact to three digits to the right of the decimal point.

    Print a blank line after each test case.


    Sample Input

    3 4 -1
    -1 2 7
    5 -1 3
    0 0 0


    Sample Output

    Triangle #1
    c = 5.000

    Triangle #2
    a = 6.708

    Triangle #3
    Impossible.

    #include <iostream>
    #include<cmath>
    using namespace std;
    int main(int argc, char *argv[])
    {
        int a,b,c,n;
        n=0;
        cout.precision(3);
        while(cin>>a>>b>>c)
        {     
               n++;
            if(a==0&& b==0 && c==0)    break;
                if(a==-1)
                {
                    if(c*c-b*b<=0) 
                    {
                    cout<<"Triangle #"    <<n <<endl;
                        cout<<"Impossible."    <<endl;
                        cout<<endl;
                    }
                    
                    else
                        {
                        cout<<"Triangle #"    <<n <<endl;
                        cout<<"a = " <<fixed<<pow(c*c-b*b,.5)    <<endl;
                        cout<<endl;    
                        
                    }
                }
                
        else    if(b==-1)
                {
                    if(c*c-a*a<=0) 
                    {
                    cout<<"Triangle #"    <<n <<endl;
                        cout<<"Impossible."    <<endl;
                        cout<<endl;
                    }
                    
                    else
                        {
                        cout<<"Triangle #"    <<n <<endl;
                        cout<<"b = " <<fixed<<pow(c*c-a*a,.5)    <<endl;
                        cout<<endl;    
                        
                    }
                }    
                
                
        else    if(c==-1)
                {
                          cout<<"Triangle #"    <<n <<endl;  
                        cout<<"c = " <<fixed<<pow(a*a+b*b,.5)    <<endl;
                        cout<<endl;    
                        
                    }
                    
                
                    
                    
                
                
        }
    
        return 0;
    }
    View Code

    #include <iostream>
    #include<cmath>
    using namespace std;
    int main(int argc, char *argv[])
    {
     int a,b,c,n;
     n=0;
     cout.precision(3);
     while(cin>>a>>b>>c)
     {    
            n++;
         if(a==0&& b==0 && c==0)    break;
       if(a==-1)
       {
        if(c*c-b*b<=0)
        {
        cout<<"Triangle #" <<n <<endl;
         cout<<"Impossible." <<endl;
         cout<<endl;
        }
        
        else
         {
         cout<<"Triangle #" <<n <<endl;
         cout<<"a = " <<fixed<<pow(c*c-b*b,.5) <<endl;
         cout<<endl; 
         
        }
       }
       
     else if(b==-1)
       {
        if(c*c-a*a<=0)
        {
        cout<<"Triangle #" <<n <<endl;
         cout<<"Impossible." <<endl;
         cout<<endl;
        }
        
        else
         {
         cout<<"Triangle #" <<n <<endl;
         cout<<"b = " <<fixed<<pow(c*c-a*a,.5) <<endl;
         cout<<endl; 
         
        }
       } 
       
       
     else if(c==-1)
       {
                 cout<<"Triangle #" <<n <<endl; 
         cout<<"c = " <<fixed<<pow(a*a+b*b,.5) <<endl;
         cout<<endl; 
         
        }
        
       
        
        
       
       
     }

     return 0;
    }

  • 相关阅读:
    利用clear清除浮动的一些问题
    配置SpringBoot方便的切换jar和war
    java并发实战:连接池实现
    canvas绘制圆角头像
    对象的合并及拷贝
    JS数组去重
    浏览器端用JS实现创建和下载图片
    超过固定宽度(或行数)显示...(或省略)
    ssh实现免密登录
    Mac 日常使用问题收集
  • 原文地址:https://www.cnblogs.com/2014acm/p/3885517.html
Copyright © 2020-2023  润新知