• hdu 1062 Text Reverse


    Text Reverse

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 16428    Accepted Submission(s): 6237

    Problem Description
    Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.
     
    Input
    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains a single line with several words. There will be at most 1000 characters in a line.
     
    Output
    For each test case, you should output the text which is processed.
     
    Sample Input
    3
    olleh !dlrow
    m'I morf .udh
    I ekil .mca
     
    Sample Output
    hello world!
    I'm from hdu.
    I like acm.

    #include <iostream>

    using namespace std;

    int main()

    {

               int n;  

                         cin>>n;  

                        getchar();

                        while(n--)  

       {  

                 char a[1005];

                           gets(a);   

                       int i,j,k;  

                for(i=0;i<strlen(a);i++)   

             {   

                      if(a[i]!=' ')    

                         {     for(j=i;a[j]!=' '&&j<strlen(a);j++);   

                                 for(k=j-1;k>=i;k--)                 cout<<a[k];

                                             i=j-1;       

                                }    

                                        else cout<<" ";   

                 }   

                        cout<<endl;     

     return 0;

    }

  • 相关阅读:
    HTML简介
    web服务器的原理
    静态网页和动态网页的区别
    HTTP协议相关原理
    C/S,B/S的应用的区别
    git撤销commit但未push的文件
    表单提交不刷新页面
    httpclient请求中文乱码问题
    web项目,@return@see@param等注解Maven install报错,不能识别
    Hive 基本操作
  • 原文地址:https://www.cnblogs.com/2014acm/p/3876536.html
Copyright © 2020-2023  润新知