• hdu 2795 Billboard


    Billboard

    Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 6749    Accepted Submission(s): 3053


    Problem Description
    At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

    On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

    Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

    When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

    If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

    Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
     
    Input
    There are multiple cases (no more than 40 cases).

    The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

    Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
     
    Output
    For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
     
    Sample Input
    3 5 5 2 4 3 3 3
     
    Sample Output
    1 2 1 3 -1
    daima :
    #include<cstdio>
    #include<iostream>
    #include<cstring>
    #define maxn 222222
    using namespace std ;
    int maxv[maxn*4] ;
    int v , x , ans ;
    void update( int o , int L , int R )
    {
        int lc = o*2 , rc = o*2 + 1 ;
        if( L == R ){ maxv[o] -= v ;return ; }
        int mid = ( R + L ) >> 1 ;
        if( x <= mid ) update( lc , L , mid ) ;
        else update( rc , mid+1 , R ) ;
        maxv[o] = max( maxv[lc] , maxv[rc] ) ;
    }
    void find( int o , int L , int R )
    {
        int lc = o*2 , rc = o*2 + 1 ;
        if( L == R ){ans = L ; return ;}
        int mid = ( R + L ) >> 1 ;
        //一直往左更新
        if( maxv[lc] >= v ) find( lc , L , mid ) ;
        else find( rc , mid+1 , R ) ;
    }
    int main()
    {
        int i  , n , h , w ;
        while( cin >> h >> w >> n )
        {
            if( n < h ) h = n ;
            for( i = 1 ; i <= h * 4 ; i++ )
                maxv[i] = w ;
            while( n-- )
            {
                scanf( "%d" , &v ) ;
                if( maxv[1] < v ) printf("-1\n") ;
                else{
                    find( 1 , 1 ,h ) ;
                    x = ans ;
                    printf( "%d\n" , x ) ;
                    update( 1 ,1 ,h ) ;
                }
            }
        }
    }
  • 相关阅读:
    异常处理
    注解配置的Spring MVC
    React router
    Redux管理你的React应用
    Spring.Net 初探
    有效的XML: DTD(文档类型定义)介绍(转)
    Python 目录操作(转)
    nginx做反向负载均衡,后端服务器获取真实客户端ip(转)
    以正确的方式开源 Python 项目(转)
    Linux访问Windows共享文件夹 (转)
  • 原文地址:https://www.cnblogs.com/20120125llcai/p/3119471.html
Copyright © 2020-2023  润新知