• POJ 2352 Stars 树状数组


    Stars
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 25425   Accepted: 11109

    Description

    Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.
    For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.
    You are to write a program that will count the amounts of the stars of each level on a given map.

    Input

    The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

    Output

    The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

    Sample Input

    5
    1 1
    5 1
    7 1
    3 3
    5 5

    Sample Output

    1
    2
    1
    1
    0

    Hint

    This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.
    代码:
    // 这几天郁闷呀 翘课刷题 挨抓到 听辅导员说是 处分了 我去!!
    // 处就处吧 题还是要刷 慢慢来
    
    #include<cstdio>
    using namespace std ;
    #include<iostream>
    #define M 32010
    int xt[M*2] ;
    int ans[M] ;
    int lowbit( int x ){
    	return x &( -x ) ;
    }
    void update( int x ){
    	while( x < M){
    		xt[x] += 1 ;
    		x += lowbit(x) ; 
    	}
    }
    int sum( int x ){
    	int s = 0 ;
    	while( x > 0 ){
    		s += xt[x] ;
    		x -= lowbit(x) ;
    	}
    	return s ;
    }
    int main()
    {
    	int i , y , n ,x ,  mun ;
    	while( cin >> n ){
    		mun = 0 ;
    		memset( xt , 0 , sizeof(xt)) ;
    		memset( ans , 0 , sizeof(ans) ) ;
    		for( i = 1; i <= n ;i++){
    			scanf( "%d%d" , &x , &y ) ;
    			x++ ;// 因为 题目给的 x 可能为 0 所以要加一 防止 死循环
    	        update(x) ;
    			ans[sum(x)]++ ;  // sum(x) 找比x 小或者 等于的数个数 
    			//cout << sum(x) << endl ;
    		}
    		for( i = 1; i <= n ; i++)
    			cout << ans[i] << endl ;
    	}
    }
    

      

  • 相关阅读:
    南邮PHP反序列化
    偏移脚本
    nginx配置不当导致的目录遍历下载漏洞-“百度杯”CTF比赛 2017 二月场
    初识smarty
    weblogic nmap扫描脚本
    巅峰极客CTF writeup[上]
    JS调用免费接口根据ip查询位置
    JS调用免费接口根据ip查询位置
    JS一维数组、多维数组和对象的混合使用
    JS一维数组、多维数组和对象的混合使用
  • 原文地址:https://www.cnblogs.com/20120125llcai/p/3038911.html
Copyright © 2020-2023  润新知