• HDU 1710 二叉树的遍历 Binary Tree Traversals


    Binary Tree Traversals

    Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 4330    Accepted Submission(s): 1970


    Problem Description
    A binary tree is a finite set of vertices that is either empty or consists of a root r and two disjoint binary trees called the left and right subtrees. There are three most important ways in which the vertices of a binary tree can be systematically traversed or ordered. They are preorder, inorder and postorder. Let T be a binary tree with root r and subtrees T1,T2.

    In a preorder traversal of the vertices of T, we visit the root r followed by visiting the vertices of T1 in preorder, then the vertices of T2 in preorder.

    In an inorder traversal of the vertices of T, we visit the vertices of T1 in inorder, then the root r, followed by the vertices of T2 in inorder.

    In a postorder traversal of the vertices of T, we visit the vertices of T1 in postorder, then the vertices of T2 in postorder and finally we visit r.

    Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence.
     
    Input
    The input contains several test cases. The first line of each test case contains a single integer n (1<=n<=1000), the number of vertices of the binary tree. Followed by two lines, respectively indicating the preorder sequence and inorder sequence. You can assume they are always correspond to a exclusive binary tree.
     
    Output
    For each test case print a single line specifying the corresponding postorder sequence.
     
    Sample Input
    9 1 2 4 7 3 5 8 9 6 4 7 2 1 8 5 9 3 6
     
    Sample Output
    7 4 2 8 9 5 6 3 1
     
    Source
     
    Recommend
    lcy   |   We have carefully selected several similar problems for you:  1707 1709 1509 1512 1714 
     
    #include<stdio.h>
    #include<string.h>
    int str1[1005],str2[1005],str3[1005];
    int sum;
    int getlen(int root,int str2[]){
       int cnt=0;
       int i=0;
       while(1){
          if(str2[i]==root)
            return cnt;
          i++;
          cnt++;
    
       }
    }
    void change(int m,int str1[],int str2[]){
        if(m==0)
            return ;
    int    len=getlen(str1[0],str2);
        change(len,str1+1,str2);
        change(m-1-len,str1+1+len,str2+len+1);
        str3[++sum]=str1[0];
    }
    int main(){
       int n;
       while(scanf("%d",&n)!=EOF){
            sum=-1;
          memset(str1,0,sizeof(str1));
          memset(str2,0,sizeof(str2));
          memset(str3,0,sizeof(str3));
          for(int i=0;i<n;i++)
            scanf("%d",&str1[i]);
          for(int i=0;i<n;i++)
            scanf("%d",&str2[i]);
          change(n,str1,str2);
          for(int i=0;i<n;i++)
            printf("%d%c",str3[i],i==n-1?'
    ':' ');
       }
       return 0;
    }
  • 相关阅读:
    Dubbo 安装监控中心
    Docker安装RabbitMQ
    Python 3 字符串转MD5形式
    Ubuntu 安装jupyter notebook
    设计模式学习-合成模式
    ubuntu 下安装jupyter
    使用物理备份恢复数据库
    matplotlib 中的subplot的用法
    pandas中关于DataFrame的groupby方法,如何取出分组的ID(行名称)和ID对应的个数
    java编程中'为了性能'一些尽量做到的地方
  • 原文地址:https://www.cnblogs.com/13224ACMer/p/4669101.html
Copyright © 2020-2023  润新知