• poj1258 Agri-Net 最小生成树


    Agri-Net
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 44032   Accepted: 18001

    Description

    Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
    Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
    Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
    The distance between any two farms will not exceed 100,000. 

    Input

    The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

    Output

    For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

    Sample Input

    4
    0 4 9 21
    4 0 8 17
    9 8 0 16
    21 17 16 0
    

    Sample Output

    28

    Source

     
     
     
     
     
     
     
     
     
     
     
     
     
     
     
     
     
     
     
     

    #include<stdio.h>
    #include<string.h>
    int map[105][105];
    int dis[105],vis[105];
    int n;
    #define inf 999999999
    int prim(int u){
    int sum=0;
    for(int i=1;i<=n;i++){
    dis[i]=map[u][i];
    }
    vis[u]=1;
    for(int i=1;i<n;i++){
    int tmin=inf;
    int temp;
    for(int j=1;j<=n;j++){
    if(dis[j]<tmin&&!vis[j]){
    tmin=dis[j];
    temp=j;
    }
    }
    sum+=tmin;
    vis[temp]=1;
    for(int k=1;k<=n;k++){
    if(dis[k]>map[temp][k]&&!vis[k])
    dis[k]=map[temp][k];
    }
    }
    return sum;
    }
    int main(){
    while(scanf("%d",&n)!=EOF){
    memset(vis,0,sizeof(vis));
    memset(dis,0,sizeof(dis));
    memset(map,0,sizeof(map));
    for(int i=1;i<=n;i++){
    for(int j=1;j<=n;j++){
    scanf("%d",&map[i][j]);
    }
    }
    printf("%d ",prim(1));

    }
    return 0;
    }

  • 相关阅读:
    Java实现 蓝桥杯VIP 算法训练 接水问题
    Java实现 蓝桥杯VIP 算法训练 接水问题
    Java实现 蓝桥杯VIP 算法训练 接水问题
    谈Delphi中SSL协议的应用(好多相关文章)
    DELPHI中IDE宏录制小用
    SQLite数据库的体系结构(翻译自sqlite.org)
    NewPascal(也许只是对FreePascal的一种封装)
    Loongnix 系统(MIPS Linux)
    死锁的解决经历
    获得WCF Client端的本地端口
  • 原文地址:https://www.cnblogs.com/13224ACMer/p/4629972.html
Copyright © 2020-2023  润新知