• HDU2056JAVA


    Rectangles

    Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 20375    Accepted Submission(s): 6607


    Problem Description
    Given two rectangles and the coordinates of two points on the diagonals of each rectangle,you have to calculate the area of the intersected part of two rectangles. its sides are parallel to OX and OY .
     
    Input
    Input The first line of input is 8 positive numbers which indicate the coordinates of four points that must be on each diagonal.The 8 numbers are x1,y1,x2,y2,x3,y3,x4,y4.That means the two points on the first rectangle are(x1,y1),(x2,y2);the other two points on the second rectangle are (x3,y3),(x4,y4).
     
    Output
    Output For each case output the area of their intersected part in a single line.accurate up to 2 decimal places.
     
    Sample Input
    1.00 1.00 3.00 3.00 2.00 2.00 4.00 4.00
    5.00 5.00 13.00 13.00 4.00 4.00 12.50 12.50
     
    Sample Output
    1.00
    56.25

    import java.util.Scanner;

     class Main{


    public static void main(String[] args) {


    Scanner cin=new Scanner(System.in);
    while(cin.hasNext()){
    double t;
    double sum=0.0;
    double x1=cin.nextDouble();
    double y1=cin.nextDouble();
    double x2=cin.nextDouble();
    double y2=cin.nextDouble();
    double x3=cin.nextDouble();
    double y3=cin.nextDouble();
    double x4=cin.nextDouble();
    double y4=cin.nextDouble();
    if(x1>x2){t=x1;x1=x2;x2=t;}
    if(y1>y2){t=y1;y1=y2;y2=t;}
    if(x3>x4){t=x3;x3=x4;x4=t;}
    if(y3>y4){t=y3;y3=y4;y4=t;}
    x1=max(x1,x3);
    x2=min(x2,x4);
    y1=max(y1,y3);
    y2=min(y2,y4);
    if(x1>x2||y1>y2){
    System.out.println("0.00");
    }
    else{
    sum=(x2-x1)*(y2-y1);
    System.out.printf("%.2f",sum);
    System.out.println();
    }

    }
    }
    private static double min(double x2, double x4) {
    if(x2<x4)
    return x2;
    else
    return x4;
    }
    private static double max(double x1, double x3) {
    if(x1>x3)
    return x1;
    else
    return x3;
    }
    }

    这个地方要注意的是的判断一下图形是否相交,如果不相交,还是要输出按题目中的输出要求:0.00;不然就会出错,这个题目只有相交和分离两种状态;

  • 相关阅读:
    用自己的话描述wcf中的传输安全与消息安全的区别(一)
    web服务器( nginx )及请求代理
    windows系统安装
    邮箱使用
    常见dos命令总结
    前端技术碰到的陌生单词
    前端工作思考
    table标签详解
    PC 端响应式布局
    HTML标签嵌套规则
  • 原文地址:https://www.cnblogs.com/1314wamm/p/5531957.html
Copyright © 2020-2023  润新知