• hdu 5364 (bc#50 1001) Distribution money


    Distribution money

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
    Total Submission(s): 276    Accepted Submission(s): 163


    Problem Description
    AFA want to distribution her money to somebody.She divide her money into n same parts.One who want to get the money can get more than one part.But if one man's money is more than the sum of all others'.He shoule be punished.Each one who get a part of money would write down his ID on that part.
     
    Input
    There are multiply cases.
    For each case,there is a single integer n(1<=n<=1000) in first line.
    In second line,there are n integer a1,a2...an(0<=ai<10000)ai is the the ith man's ID.
     
    Output
    Output ID of the man who should be punished.
    If nobody should be punished,output -1.
     
    Sample Input
    3 1 1 2 4 2 1 4 3
     
    Sample Output
    1 -1
     
    Source
     
    水.
    比赛的时候傻逼两发,妈蛋
    没读完就break了....
    /*************************************************************************
        > File Name: code/bc/#50/1001.cpp
        > Author: 111qqz
        > Email: rkz2013@126.com 
        > Created Time: 2015年08月08日 星期六 19时02分16秒
     ************************************************************************/
    
    #include<iostream>
    #include<iomanip>
    #include<cstdio>
    #include<algorithm>
    #include<cmath>
    #include<cstring>
    #include<string>
    #include<map>
    #include<set>
    #include<queue>
    #include<vector>
    #include<stack>
    #define y0 abc111qqz
    #define y1 hust111qqz
    #define yn hez111qqz
    #define j1 cute111qqz
    #define tm crazy111qqz
    #define lr dying111qqz
    using namespace std;
    #define REP(i, n) for (int i=0;i<int(n);++i)  
    typedef long long LL;
    typedef unsigned long long ULL;
    const int inf = 0x7fffffff;
    int cnt[10005];
    int n;
    int x;
    int main()
    {
        while (scanf("%d",&n)!=EOF)
        {
        bool flag = false;
        memset(cnt,0,sizeof(cnt));
        for ( int i = 0 ; i < n ; i ++ )
        {
            scanf("%d",&x);
            cnt[x]++;
            if (flag) continue;
            if (cnt[x]>n/2)
            {
            flag = true;
            cout<<x<<endl;
            }
        }
        if (!flag)
        {
            cout<<-1<<endl;
        }
        }
        return 0;
    }
     
  • 相关阅读:
    Annotation Type ManyToMany->>>>>Oracle
    windows 控制台默认为UTF-8显示的方法
    springboot读取配置文件
    Spring Boot配置文件放在jar外部
    Vue自定义过滤器
    vue中limitBy,filterBy,orderBy的用法
    track-by的使用
    Vue的computed属性
    vue实现百度下拉框
    Cas服务器以及客户端搭建
  • 原文地址:https://www.cnblogs.com/111qqz/p/4715231.html
Copyright © 2020-2023  润新知