• poj 3087 Shuffle'm Up (bfs)


    Description

    A common pastime for poker players at a poker table is to shuffle stacks of chips. Shuffling chips is performed by starting with two stacks of poker chips, S1 and S2, each stack containing C chips. Each stack may contain chips of several different colors.

    The actual shuffle operation is performed by interleaving a chip from S1 with a chip from S2 as shown below for C = 5:

    The single resultant stack, S12, contains 2 * C chips. The bottommost chip of S12 is the bottommost chip from S2. On top of that chip, is the bottommost chip from S1. The interleaving process continues taking the 2nd chip from the bottom of S2 and placing that on S12, followed by the 2nd chip from the bottom of S1 and so on until the topmost chip from S1 is placed on top of S12.

    After the shuffle operation, S12 is split into 2 new stacks by taking the bottommost C chips from S12 to form a new S1 and the topmost C chips from S12 to form a new S2. The shuffle operation may then be repeated to form a new S12.

    For this problem, you will write a program to determine if a particular resultant stack S12 can be formed by shuffling two stacks some number of times.

    Input

    The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

    Each dataset consists of four lines of input. The first line of a dataset specifies an integer C, (1 ≤ C ≤ 100) which is the number of chips in each initial stack (S1 and S2). The second line of each dataset specifies the colors of each of the C chips in stack S1, starting with the bottommost chip. The third line of each dataset specifies the colors of each of the C chips in stack S2 starting with the bottommost chip. Colors are expressed as a single uppercase letter (A through H). There are no blanks or separators between the chip colors. The fourth line of each dataset contains 2 * C uppercase letters (A through H), representing the colors of the desired result of the shuffling of S1 and S2 zero or more times. The bottommost chip’s color is specified first.

    Output

    Output for each dataset consists of a single line that displays the dataset number (1 though N), a space, and an integer value which is the minimum number of shuffle operations required to get the desired resultant stack. If the desired result can not be reached using the input for the dataset, display the value negative 1 (−1) for the number of shuffle operations.

    Sample Input

    2
    4
    AHAH
    HAHA
    HHAAAAHH
    3
    CDE
    CDE
    EEDDCC

    Sample Output

    1 2
    2 -1

    用bfs写的,但是其实就是个模拟啊喂!

    只有一种操作,何谈最短? 一直往下写就行了.

    有一点疑惑,就是map的初始值

    比如我定义的 map<string,int>d;它的初始的value是什么?随机值?0?还是什么,百度了下,没找到,求指教.

    /*************************************************************************
        > File Name: code/2015summer/searching/GG.cpp
        > Author: 111qqz
        > Email: rkz2013@126.com 
        > Created Time: 2015年07月24日 星期五 23时54分00秒
     ************************************************************************/
    
    #include<iostream>
    #include<iomanip>
    #include<cstdio>
    #include<algorithm>
    #include<cmath>
    #include<cstring>
    #include<string>
    #include<map>
    #include<set>
    #include<queue>
    #include<vector>
    #include<stack>
    #define y0 abc111qqz
    #define y1 hust111qqz
    #define yn hez111qqz
    #define j1 cute111qqz
    #define tm crazy111qqz
    #define lr dying111qqz
    using namespace std;
    #define REP(i, n) for (int i=0;i<int(n);++i)  
    typedef long long LL;
    typedef unsigned long long ULL;
    map<string,int>d;
    string st1,st2,tar;
    int n;
    bool flag;
    string add(string a,string b)
    {
        string res="";
        int len = a.length();
        for ( int i = 0 ; i < len ; i++ )
        {
          res+=b[i];
          res+=a[i];
        }
        return res;
    }
    void bfs()
    {
        queue<string>q;
        string str=add(st1,st2);
        q.push(str);
        d[str]=1;
        while (!q.empty())
        {
          string pst = q.front();
          q.pop();
          if (pst==tar)
          {
            flag = true;
            return;
          }
          string s1=pst.substr(0,n);
          string s2=pst.substr(n,n);
          string tmps = add(s1,s2);
          if (d[tmps]>0) 
          {
            flag = false;
            return;
          }
          d[tmps]=d[pst]+1;
          q.push(tmps);
        }
    }
    int main()
    {
        int T;
        int cas = 0;
        cin>>T;
    
        while (T--)
        {
          d.clear();
          cas++;
          cin>>n;
          cin>>st1>>st2>>tar;
          bfs();
          if (flag)
          {
            cout<<cas<<" "<<d[tar]<<endl;
          }
          else
          {
            cout<<cas<<" "<<-1<<endl;
          }
        }
      
        return 0;
    }
  • 相关阅读:
    安全相关小知识
    http小知识
    跨域资源共享 CORS
    Django——CRSF攻击及处理
    Django——XSS攻击及处理
    Django——模版层(前后端交互编码方式,django模板使用的两种方式,模板语法之变量&深度查询句点符,模板渲染成标签还是原字符串,过滤器+自定义,标签+自定义)
    Django——Postman介绍及安装, 测试项目
    Django——视图层(请求&响应对象,cbv和fbv,文件上传)
    一个http请求从浏览器发出去,经历的过程(即上网流程)
    Django——有名分组 无名分组,反向解析,名称空间
  • 原文地址:https://www.cnblogs.com/111qqz/p/4675099.html
Copyright © 2020-2023  润新知