• PAT1024:Palindromic Number


    1024. Palindromic Number (25)

    时间限制
    400 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

    Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

    Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

    Input Specification:

    Each input file contains one test case. Each case consists of two positive numbers N and K, where N (<= 1010) is the initial numer and K (<= 100) is the maximum number of steps. The numbers are separated by a space.

    Output Specification:

    For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

    Sample Input 1:
    67 3
    
    Sample Output 1:
    484
    2
    
    Sample Input 2:
    69 3
    
    Sample Output 2:
    1353
    3

    思路

    判断一个数n是不是回文数,不是则重复step步这样的操作:
    n = n + n的逆序数(比如n = 123 + 321 = 444)。
    直到n为回文数或者step > k。
    输出n,step。

    注意:用int,long等都会溢出,所以直接操作字符串进行加法运算。

    代码
    #include<iostream>
    #include<algorithm>
    using namespace std;
    bool isPNum(const string& s)
    {
        for(int i = 0,j = s.size() - 1;i < j;i++,j--)
        {
            if(s[i] != s[j])
                return false;
        }
        return true;
    }
    
    string Add(const string& o,const string &s)
    {
        string tmp = "";
        int len = o.size(),carry = 0;
        for(int i = len - 1;i >= 0;i--)
        {
           int t1 = o[i] - '0',
               t2 = s[i] - '0';
           int cur = (t1 + t2 + carry) % 10;
           tmp += to_string(cur);
           carry = (t1 + t2 + carry) / 10;
        }
        if(carry > 0)
           tmp += "1";
        reverse(tmp.begin(),tmp.end());
        return tmp;
    }
    
    int main()
    {
        string n;
        int k;
        while(cin >> n >> k)
        {
            int step = 0;
            while(++step <= k)
            {
                if(isPNum(n))
                    break;
                string t = n;
                reverse(t.begin(),t.end());
                n = Add(n,t);
            }
            cout << n << endl;
            cout << step - 1 << endl;
        }
    }
    
    
    

      

     
  • 相关阅读:
    【python】Excel从源表提取相应信息到目标表格
    Vue.config.productionTip 关闭生产提示
    [elementui]多行confirm
    [vue]防抖(debounce) 和 节流(throttling)
    C#的面向对象之继承与多态
    C#中接口与抽象类
    为iPhone开发iPad风格的弹出窗口
    新闻资讯APP开发流程(五) MainView.js
    titanium开发实例社交APP一之登录窗口
    titanium开发实例社交APP二之注册窗口
  • 原文地址:https://www.cnblogs.com/0kk470/p/7929842.html
Copyright © 2020-2023  润新知