• PAT1129:Recommendation System


    1129. Recommendation System (25)

    时间限制
    400 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    Recommendation system predicts the preference that a user would give to an item. Now you are asked to program a very simple recommendation system that rates the user's preference by the number of times that an item has been accessed by this user.

    Input Specification:

    Each input file contains one test case. For each test case, the first line contains two positive integers: N (<= 50000), the total number of queries, and K (<= 10), the maximum number of recommendations the system must show to the user. Then given in the second line are the indices of items that the user is accessing -- for the sake of simplicity, all the items are indexed from 1 to N. All the numbers in a line are separated by a space.

    Output Specification:

    For each case, process the queries one by one. Output the recommendations for each query in a line in the format:

    query: rec[1] rec[2] ... rec[K]

    where query is the item that the user is accessing, and rec[i] (i = 1, ... K) is the i-th item that the system recommends to the user. The first K items that have been accessed most frequently are supposed to be recommended in non-increasing order of their frequencies. If there is a tie, the items will be ordered by their indices in increasing order.

    Note: there is no output for the first item since it is impossible to give any recommendation at the time. It is guaranteed to have the output for at least one query.

    Sample Input:
    12 3
    3 5 7 5 5 3 2 1 8 3 8 12
    
    Sample Output:
    5: 3
    7: 3 5
    5: 3 5 7
    5: 5 3 7
    3: 5 3 7
    2: 5 3 7
    1: 5 3 2
    8: 5 3 1
    3: 5 3 1
    8: 3 5 1
    12: 3 5 8

    思路
    1.题目要求每次用户点击(输入)一个商品时,要把它之前点击次数前k大的商品打印出来。
    2.可以构建一个item类并使用set容器的自动排序完成。item的"<"运算符需要重载,使其满足在set内部的排序条件如下:
    1)点击次数越多的item越靠前
    2)如果两个item点击次数相同,则比较它们的编号,编号小的靠前。

    代码
    #include<iostream>
    #include<vector>
    #include<set>
    using namespace std;
    vector<int> appear_time(50001,0);
    class item
    {
    public:
        int val;
        int cnt;
        item(int _val,int _cnt){val = _val;cnt = _cnt;}
        bool operator <(const item& a) const
        {
            return cnt == a.cnt? val < a.val:cnt > a.cnt;
        }
    };
    
    int main()
    {
       int n,k;
       set<item> items;
       while(cin >> n >> k)
       {
          item tmp(0,1);
          cin >> tmp.val;
          appear_time[tmp.val]++;
          items.insert(tmp);
          for(int i = 1;i < n;i++)
          {
             int a;
             cin >> a;
             cout << a <<":";
             int index = 0;
             for(set<item>::iterator it = items.begin();index < k && it != items.end();it++,index++)
                cout << " " << it->val;
             cout << endl;
             auto iter = items.find(item(a,appear_time[a]));
             appear_time[a]++;
             if(iter == items.end())
                items.insert(item(a,1));
             else
             {
                 items.erase(iter);
                 items.insert(item(a,appear_time[a]));
             }
          }
       }
    }
    

      

  • 相关阅读:
    新的工作开始
    昨日的世界
    【Drools-开源业务规则引擎】入门实例(含源码)
    【cs229-Lecture7】支持向量机(SVM)
    【2014年12月6日】HR交流会
    【cs229-Lecture5】生成学习算法:1)高斯判别分析(GDA);2)朴素贝叶斯(NB)
    【图算法】Dijkstra算法及变形
    【图算法】综述
    【云迁移论文笔记】A Comparison of On-premise to Cloud Migration Approaches
    【云迁移论文笔记】Cloud Migration Research:A Systematic Review
  • 原文地址:https://www.cnblogs.com/0kk470/p/7885397.html
Copyright © 2020-2023  润新知