• PAT1126:Eulerian Path


    1126. Eulerian Path (25)

    时间限制
    300 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    In graph theory, an Eulerian path is a path in a graph which visits every edge exactly once. Similarly, an Eulerian circuit is an Eulerian path which starts and ends on the same vertex. They were first discussed by Leonhard Euler while solving the famous Seven Bridges of Konigsberg problem in 1736. It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit, and such graphs are called Eulerian. If there are exactly two vertices of odd degree, all Eulerian paths start at one of them and end at the other. A graph that has an Eulerian path but not an Eulerian circuit is called semi-Eulerian. (Cited from https://en.wikipedia.org/wiki/Eulerian_path)

    Given an undirected graph, you are supposed to tell if it is Eulerian, semi-Eulerian, or non-Eulerian.

    Input Specification:

    Each input file contains one test case. Each case starts with a line containing 2 numbers N (<= 500), and M, which are the total number of vertices, and the number of edges, respectively. Then M lines follow, each describes an edge by giving the two ends of the edge (the vertices are numbered from 1 to N).

    Output Specification:

    For each test case, first print in a line the degrees of the vertices in ascending order of their indices. Then in the next line print your conclusion about the graph -- either "Eulerian", "Semi-Eulerian", or "Non-Eulerian". Note that all the numbers in the first line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.

    Sample Input 1:
    7 12
    5 7
    1 2
    1 3
    2 3
    2 4
    3 4
    5 2
    7 6
    6 3
    4 5
    6 4
    5 6
    
    Sample Output 1:
    2 4 4 4 4 4 2
    Eulerian
    
    Sample Input 2:
    6 10
    1 2
    1 3
    2 3
    2 4
    3 4
    5 2
    6 3
    4 5
    6 4
    5 6
    
    Sample Output 2:
    2 4 4 4 3 3
    Semi-Eulerian
    
    Sample Input 3:
    5 8
    1 2
    2 5
    5 4
    4 1
    1 3
    3 2
    3 4
    5 3
    
    Sample Output 3:
    3 3 4 3 3
    Non-Eulerian

    思路
    判断一个图:
    1)是不是欧拉图。
    2)半欧拉图。
    3)二者都不是。

    1.邻接表存储图,dfs先确定连通性。不连通则为3)
    2.在图连通的基础上确定是欧拉图还是半欧拉图。点的度数全为偶数为欧拉图,恰好有两个点度数为奇数是半欧拉图,其余情况二者皆不是。

    代码
    #include<vector>
    #include<iostream>
    using namespace std;
    int cnt = 0;
    vector<bool> isvisit(501,false);
    
    void dfs(int root,const  vector<vector<int>>& graph)
    {
        isvisit[root] = true;
        cnt++;
        for(int i = 0;i < graph[root].size();i++)
        {
            if(!isvisit[graph[root][i]])
                dfs(graph[root][i],graph);
        }
    }
    
    int main()
    {
        int N,M;
        while(cin >> N >> M)
        {
            vector<vector<int>> vertices(N+1);
            for(int i = 0;i < M;i++)
            {
                int a,b;
                cin >> a >> b;
                vertices[a].push_back(b);
                vertices[b].push_back(a);
            }
            int countOdds = 0;
            for(int i = 1;i <= N;i++)
            {
                if(i == 1)
                    cout << vertices[i].size();
                else
                    cout << " " << vertices[i].size();
                if(vertices[i].size() % 2 != 0 )
                {
                    countOdds++;
                }
            }
            cout << endl;
            dfs(1,vertices);
    
            if(cnt == N && countOdds == 0)
                cout << "Eulerian" << endl;
            else if(cnt == N && countOdds == 2)
                cout << "Semi-Eulerian" << endl;
            else
                cout << "Non-Eulerian" << endl;
        }
    }
    

      

  • 相关阅读:
    Spark Streaming:大规模流式数据处理的新贵
    HBase源码学习系列
    Hadoop源码分析之Configuration
    sql server存储引擎启动错误(SQL Server could not spawn FRunCM thread)
    Redis(1.15)Redis监控(待写)
    Redis(1.14)Redis日常管理与维护
    Redis(1.13)Redis cluster 分布式集群手动配置
    (5.3.5)数据库迁移——数据库与文件组的位置迁移(同一实例)
    Redis(1.12)Redis cluster搭建常见错误
    Redis(1.11)Redis4.0.11 cluster 分布式集群搭建
  • 原文地址:https://www.cnblogs.com/0kk470/p/7761130.html
Copyright © 2020-2023  润新知