• PAT1031:Hello World for U


    1031. Hello World for U (20)

    时间限制
    400 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

    h  d
    e  l
    l  r
    lowo
    
    That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.

    Input Specification:

    Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

    Output Specification:

    For each test case, print the input string in the shape of U as specified in the description.

    Sample Input:
    helloworld!
    
    Sample Output:
    h   !
    e   d
    l   l
    lowor

    思路

    对称U型格式输出一个字符串。

    穷举找出满足   n1 + n3 + n2 = N + 2(3 <= n2 <= N , n3 = n1 <= n2)  的n1,n3最大值即可。

    代码

    #include<iostream>
    #include<string>
    #include<math.h>
    using namespace std;
    int main()
    {
      string s;
      while(cin >> s)
      {
          int N = s.size();
          int maxn3 = -1;
          for(int n2 = 3;n2 <= N;n2++)
          {
              for(int n3 = 0;n3 <=n2;n3++)
              {
                  if(2*n3 + n2 - 2 == N)
                    maxn3 = max(maxn3,n3);
              }
          }
    
          int n1 = maxn3,n2 = N + 2 - 2 * n1;
    
          //print
          int i = 0;
          for(i = 0;i < n1 - 1;i++)
          {
              cout << s[i];
              for(int j = 0; j < n2 - 2;j++)
                cout << " ";
              cout << s[N - i - 1] << endl;
          }
          int rest = N - i - 1;
          for(;i <= rest;i++)
          {
              cout << s[i];
          }
          cout << endl;
      }
    }
  • 相关阅读:
    Golang 版本 支付宝支付SDK app支付接口2.0
    用 Certbot-auto 在 letsencrypt.org申请免费 SSL 证书实现 HTTPS
    Go类型断言demo
    签名算法
    golang cron定时任务简单实现
    Chapter Zero 0.2.2 内存
    Linux-系统目录结构
    Linux-关于Bash
    Chapter Zero 0.2.1 执行运算与判断的CPU
    Chapter Zero 0.1.4 计算机上常用的计算单位
  • 原文地址:https://www.cnblogs.com/0kk470/p/7623059.html
Copyright © 2020-2023  润新知