• PAT1011:World Cup Betting


    1011. World Cup Betting (20)

    时间限制
    400 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

    Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

    For example, 3 games' odds are given as the following:

     W    T    L
    1.1  2.5  1.7
    1.2  3.0  1.6
    4.1  1.2  1.1
    

    To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1*3.0*2.5*65%-1)*2 = 37.98 yuans (accurate up to 2 decimal places).

    Input

    Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

    Output

    For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

    Sample Input
    1.1 2.5 1.7
    1.2 3.0 1.6
    4.1 1.2 1.1
    
    Sample Output
    T T W 37.98

    思路
    很简单,找出每次比赛三种结果的最大赔率的那次结果,每三次比赛输出一下利润,套公式即可。需要特别注意保留n位小数时四舍五入和float转int的坑。
    代码
    #include<iostream>
    #include<vector>
    #include<math.h>
    using namespace std;
    char a[4] = "WTL";
    const float t = 0.65;
    const float point = 0.5;
    
    
    int main()
    {
      vector<float> bet(3);
      vector<float> maxodd(3);
      vector<char> result;
      int N = 0;
      while(cin >> bet[0] >> bet[1] >> bet[2])
      {
         int pos = 0;
         if(max(bet[0],bet[1]) < bet[2])
         {
             maxodd[N++] = bet[2];
             pos = 2;
         }
         else if(bet[0] > bet[1])
         {
             maxodd[N++] = bet[0];
             pos = 0;
         }
         else
         {
             maxodd[N++] = bet[1];
             pos = 1;
         }
         result.push_back(a[pos]);
         if(N == 3)
         {
            float profit = 200 * (maxodd[0] * maxodd[1] * maxodd[2] * t - 1) + point;
            int temp = (int)profit;
            float maxprofit = ((float)temp)/100;
            for(int i = 0;i < 3;i++)
                cout << result[i] << " ";
            cout << maxprofit << endl;
            N = 0;
         }
      }
    }
    
    
    
     
  • 相关阅读:
    python 多进程操作
    python 什么是全局解释器锁GIL
    cloudstack api调用python
    cloudstack模板
    微型计算器
    a++与=++a的区别
    js自调用函数的实现方式
    .net利用NPOI导入导出Excel
    linux系统下c程序分多文件实现
    线程的优先级
  • 原文地址:https://www.cnblogs.com/0kk470/p/7623055.html
Copyright © 2020-2023  润新知