• PAT1064: Compelte Binary Search Tree


    1064. Complete Binary Search Tree (30)

    时间限制
    100 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

    • The left subtree of a node contains only nodes with keys less than the node's key.
    • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
    • Both the left and right subtrees must also be binary search trees.

    A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

    Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

    Output Specification:

    For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

    Sample Input:
    10
    1 2 3 4 5 6 7 8 9 0
    
    Sample Output:
    6 3 8 1 5 7 9 0 2 4

    思路
    1.二叉搜索树的中序遍历是一个递增的序列,所以先将输入后的节点数组升序排序
    2.完全二叉树以数组描述时,索引为i的节点的左右孩子的索引分别为2 * i和2 * i + 1。
    3.将排好序的节点以中序遍历的形式来构造完全二叉搜索树。
    4.遍历构造好的数组即为这棵树的层次遍历
    代码
    #include<iostream>
    #include<algorithm>
    #include<vector>
    using namespace std;
    
    const int MAX = 1010;
    vector<int> nodes(MAX);
    vector<int> tree(MAX);
    int N,index;   //number of nodes && index of Nodes
    
    void buildtree(int root)
    {
        if(root > N)
            return;
        int left = root*2,right = root*2 + 1;
        buildtree(left);
        tree[root] = nodes[index++];
        buildtree(right);
    
    }
    
    int main()
    {
       while(cin >> N)
       {
        //input
         for(int i = 1; i <= N;i++)
            cin >> nodes[i];
         sort(nodes.begin() + 1,nodes.begin() + 1 + N);
         //build tree
         index = 1;
         buildtree(1);
    
         //print tree
         cout << tree[1];
         for(int i = 2;i <= N;i++)
            cout <<" " << tree[i];
         cout << endl;
       }
    }
     
  • 相关阅读:
    hdu 4465 概率称号
    Log4j配置文件位置+Spring数据源配置文件位置
    Centos 6.5下一个SNMP简单配置(snmp protocol v3,监控宝)
    过程 线 多线程 并发 同步异步
    django简单图表
    十年
    一起写2048(160行python代码)
    leetcode
    匹配算法重载方法
    串行卧重建10:小设计,而不是大布局
  • 原文地址:https://www.cnblogs.com/0kk470/p/7622966.html
Copyright © 2020-2023  润新知