• Atlantis HDU


     Problem Description

    There are several ancient Greek texts that contain descriptions of the fabled island Atlantis. Some of these texts even include maps of parts of the island. But unfortunately, these maps describe different regions of Atlantis. Your friend Bill has to know the total area for which maps exist. You (unwisely) volunteered to write a program that calculates this quantity.
     

    Input

    The input file consists of several test cases. Each test case starts with a line containing a single integer n (1<=n<=100) of available maps. The n following lines describe one map each. Each of these lines contains four numbers x1;y1;x2;y2 (0<=x1<x2<=100000;0<=y1<y2<=100000), not necessarily integers. The values (x1; y1) and (x2;y2) are the coordinates of the top-left resp. bottom-right corner of the mapped area.

    The input file is terminated by a line containing a single 0. Don’t process it.
     

    Output

    For each test case, your program should output one section. The first line of each section must be “Test case #k”, where k is the number of the test case (starting with 1). The second one must be “Total explored area: a”, where a is the total explored area (i.e. the area of the union of all rectangles in this test case), printed exact to two digits to the right of the decimal point.

    Output a blank line after each test case.
     
    Sample Input
    2 10 10 20 20 15 15 25 25.5 0
     
    Sample Output
    Test case #1 Total explored area: 180.00
     
    Source

    题解:

    好像这个是线段树扫描线矩阵合并模板

    #include<cstdio>
    #include <algorithm>
    #include <cstring>
    using namespace std;
    #define lson l, m, rt << 1
    #define rson m + 1, r, rt << 1 | 1
    const int MAXN=300;
    const int INF=0x3f3f3f3f;
    const int MOD=1e9+7;
    int n;
    double all[MAXN];
    struct Seg{
        double l,r,h;
        int d;
        Seg(){};//这是一个构造函数,应与结构体或类名相同
        Seg(double l,double r,double h,int d):l(l),r(r),h(h),d(d){}
        bool operator <(const Seg& rhs )const {
            return h<rhs.h;
        }
    }a[MAXN];
    int cnt[MAXN<<2];//懒标记
    double sum[MAXN<<2];
    
    
    void pushup(int l,int r,int rt )
    {
        if(cnt[rt]) sum[rt]=all[r+1]-all[l];
        else if(l==r) sum[rt]=0;
        else{
            sum[rt]=sum[rt<<1]+sum[rt<<1|1];
        }
    }
    
    void update(int L,int R,int v,int l,int r,int rt)//区间更新
    {
        if(l>=L&&r<=R)
        {
            cnt[rt]+=v;
            pushup(l,r,rt);
            return;
        }
        int mid=(l+r)>>1;
        if(L<=mid)update(L,R,v,l,mid,rt<<1);
        if(R>mid) update(L,R,v,mid+1,r,rt<<1|1);
        pushup(l,r,rt);
    }
    
    
    
    int main()
    {
        int Case=0;
        while (scanf("%d",&n)!=EOF&&n)
        {
            double x1,y1,x2,y2;
            for (int i = 1; i <=n ; ++i) {
                scanf("%lf%lf%lf%lf",&x1,&y1,&x2,&y2);
                a[i]=Seg(x1,x2,y1,1);
                a[i+n]=Seg(x1,x2,y2,-1);
    
                all[i]=x1;all[i+n]=x2;
            }
            n<<=1;
            sort(a+1,a+1+n);//使线条从下向上排列。
    
            sort(all+1,all+n+1);
            int m=unique(all+1,all+1+n)-all-1;//这个函数是"去掉"相邻位置的重复,移到末尾
            memset(sum,0,sizeof(sum));
            memset(cnt,0, sizeof(cnt));
            double ans=0;
            for (int i = 1; i <n ; ++i) {
    
                int l=lower_bound(all+1,all+1+m,a[i].l)-all;//离散化
                int r=lower_bound(all+1,all+1+m,a[i].r)-all;
    
                if(l<r) update(l,r-1,a[i].d,1,m,1);
    
                ans+=sum[1]*(a[i+1].h-a[i].h);
            }
    
            printf("Test case #%d
    Total explored area: %.2lf
    
    ",++Case,ans);
    
        }
        return 0;
    }
    

      

  • 相关阅读:
    P2567 [SCOI2010]幸运数字 DFS+容斥定理
    Codeforces Round #462 (Div. 2) C DP
    Codeforces Round #428 (Div. 2) C. dfs
    POJ 2079 最大三角形面积(凸包)
    POJ 3608 凸包间最短距离(旋转卡壳)
    2018年全国多校算法寒假训练
    Educational Codeforces Round 37 E. Connected Components?(图论)
    UVa 1440:Inspection(带下界的最小流)***
    BZOJ 1483:[HNOI2009]梦幻布丁(链表启发式合并)
    PAT L3-016:二叉搜索树的结构(暴力)
  • 原文地址:https://www.cnblogs.com/-xiangyang/p/9446065.html
Copyright © 2020-2023  润新知