• poj_2301_Building a Space Station_mst


                          Building a Space Station
    Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64u
    Submit Status

    Description

    You are a member of the space station engineering team, and are assigned a task in the construction process of the station. You are expected to write a computer program to complete the task. 
    The space station is made up with a number of units, called cells. All cells are sphere-shaped, but their sizes are not necessarily uniform. Each cell is fixed at its predetermined position shortly after the station is successfully put into its orbit. It is quite strange that two cells may be touching each other, or even may be overlapping. In an extreme case, a cell may be totally enclosing another one. I do not know how such arrangements are possible. 

    All the cells must be connected, since crew members should be able to walk from any cell to any other cell. They can walk from a cell A to another cell B, if, (1) A and B are touching each other or overlapping, (2) A and B are connected by a `corridor', or (3) there is a cell C such that walking from A to C, and also from B to C are both possible. Note that the condition (3) should be interpreted transitively. 

    You are expected to design a configuration, namely, which pairs of cells are to be connected with corridors. There is some freedom in the corridor configuration. For example, if there are three cells A, B and C, not touching nor overlapping each other, at least three plans are possible in order to connect all three cells. The first is to build corridors A-B and A-C, the second B-C and B-A, the third C-A and C-B. The cost of building a corridor is proportional to its length. Therefore, you should choose a plan with the shortest total length of the corridors. 

    You can ignore the width of a corridor. A corridor is built between points on two cells' surfaces. It can be made arbitrarily long, but of course the shortest one is chosen. Even if two corridors A-B and C-D intersect in space, they are not considered to form a connection path between (for example) A and C. In other words, you may consider that two corridors never intersect. 

    Input

    The input consists of multiple data sets. Each data set is given in the following format. 


    x1 y1 z1 r1 
    x2 y2 z2 r2 
    ... 
    xn yn zn rn 

    The first line of a data set contains an integer n, which is the number of cells. n is positive, and does not exceed 100. 

    The following n lines are descriptions of cells. Four values in a line are x-, y- and z-coordinates of the center, and radius (called r in the rest of the problem) of the sphere, in this order. Each value is given by a decimal fraction, with 3 digits after the decimal point. Values are separated by a space character. 

    Each of x, y, z and r is positive and is less than 100.0. 

    The end of the input is indicated by a line containing a zero. 

    Output

    For each data set, the shortest total length of the corridors should be printed, each in a separate line. The printed values should have 3 digits after the decimal point. They may not have an error greater than 0.001. 

    Note that if no corridors are necessary, that is, if all the cells are connected without corridors, the shortest total length of the corridors is 0.000. 

    Sample Input

    3
    10.000 10.000 50.000 10.000
    40.000 10.000 50.000 10.000
    40.000 40.000 50.000 10.000
    2
    30.000 30.000 30.000 20.000
    40.000 40.000 40.000 20.000
    5
    5.729 15.143 3.996 25.837
    6.013 14.372 4.818 10.671
    80.115 63.292 84.477 15.120
    64.095 80.924 70.029 14.881
    39.472 85.116 71.369 5.553
    0

    Sample Output

    20.000
    0.000
    73.834


      这道题是MST水题,只是把点换成3维坐标的形式。
      上代码:

    #include<iostream>
    #include<cstring>
    #include<cmath>
    #include<iomanip>
    using namespace std;

    const int MAXN=105;
    const double INF=99999999.9;
    struct Point
    {
      double x,y,z,r;
    }point[MAXN];
    double lowc[MAXN];
    bool vis[MAXN];
    double cost[MAXN][MAXN];
    double get_dis(int i,int j)
    {
      return sqrt((point[i].x-point[j].x)*(point[i].x-point[j].x)+(point[i].y-point[j].y)*(point[i].y-point[j].y)+
      (point[i].z-point[j].z)*(point[i].z-point[j].z));
    }
    double prim(int n)      //我就是因为这里把double写成了int,结果wa了一次,细心,真的很重要啊。
    {
      memset(vis,false,sizeof(vis));
      double ans=0.0;
      vis[0]=true;
      for(int i=1;i<n;i++)
        lowc[i]=cost[0][i];
      for(int i=1;i<n;i++)
      {
        double minc=INF;
        int p=-1;
        for(int j=0;j<n;j++)
          if(!vis[j]&&lowc[j]<minc)
        {
          minc=lowc[j];
          p=j;
        }
        if(minc==INF)
          return -1;
        ans+=minc;
        vis[p]=true;
        for(int j=0;j<n;j++)
          if(!vis[j]&&cost[p][j]<lowc[j])
            lowc[j]=cost[p][j];
      }
      return ans;
    }
    int main()
    {
      int n;
      while(cin>>n)
      {
        if(n==0)
          break;
        for(int i=0;i<n;i++)
        {
          cin>>point[i].x>>point[i].y>>point[i].z>>point[i].r;
        }
        double dis;
        for(int i=0;i<n;i++)
        {
          lowc[i]=INF;
          for(int j=0;j<n;j++)
          {
            dis=get_dis(i,j)-point[i].r-point[j].r;
            if(dis<=0.000)
              cost[i][j]=cost[j][i]=0.0;
            else
              cost[i][j]=cost[j][i]=dis;      //无向图
          }
        }
        double ans=prim(n);
        cout<<setiosflags(ios::fixed)<<setprecision(3)<<ans<<endl;
      }
      return 0;
    }






  • 相关阅读:
    远程接入系统的问题
    FastReport
    通用FASTREPORT打印模块及接口方法
    cxGrid控件过滤筛选后如何获更新筛选后的数据集
    Oracle Data Integrator 12c (12.1.2)新特性
    ODI 12c 安装
    Kafka面试题
    Hadoop面试题
    Spark面试题
    JAVA面试题-数组字符串基础
  • 原文地址:https://www.cnblogs.com/-maybe/p/4247700.html
Copyright © 2020-2023  润新知