• hdu 1029 Ignatius and the Princess IV


    Ignatius and the Princess IV

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32767 K (Java/Others)
    Total Submission(s): 50812    Accepted Submission(s): 22770


    Problem Description
    "OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

    "I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

    "But what is the characteristic of the special integer?" Ignatius asks.

    "The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

    Can you find the special integer for Ignatius?
     
    Input
    The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.
     
    Output
    For each test case, you have to output only one line which contains the special number you have found.
     
    Sample Input
    5
    1 3 2 3 3
    11
    1 1 1 1 1 5 5 5 5 5 5
    7
    1 1 1 1 1 1 1
     
    Sample Output
    3
    5
    1
    #include<iostream>
    #include<string.h>
    #include<string>
    #include<map>
    using namespace std;
    int n;
    map<int,int>m;
    int main()
    {
        int x,t;
        while(cin>>n)
        {
            m.clear();
            t=(n+1)/2;
            while(n--)
            {
                cin>>x;
                m[x]++;
            }
            map<int,int>::iterator it;
            for(it=m.begin();it!=m.end();it++)
            {
                if(it->second>=t)
                {
                    cout<<it->first<<endl;
                    break;
                }
            }
        }
    }
  • 相关阅读:
    Delphi WinAPI GetWindowRect
    Delphi WMI[2] 响应网线断开
    打印两个升序链表中共同的数据
    判断一个链表是否是回文结构
    删除有序数组中的重复项
    三数之和、最接近目标值的三数之和
    删除链表倒数第N个节点
    判断回文数
    字符串转整数
    整数反转
  • 原文地址:https://www.cnblogs.com/-citywall123/p/11245628.html
Copyright © 2020-2023  润新知