• hdu 4006 The kth great number


    The kth great number

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
    Total Submission(s): 16226    Accepted Submission(s): 6110


    Problem Description
    Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.
     
    Input
    There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number. 
     
    Output
    The output consists of one integer representing the largest number of islands that all lie on one line. 
     
    Sample Input
    8 3 I 1 I 2 I 3 Q I 5 Q I 4 Q
     
    Sample Output
    1 2 3
    Hint
    Xiao Ming won't ask Xiao Bao the kth great number when the number of the written number is smaller than k. (1=<k<=n<=1000000).
     
    题意:输入I表示插入一个数,输入Q表示要你求第k大的数
     
    题解:用multiset,会自动排序,但是不会去重
     
    #include<iostream>
    #include<algorithm>
    #include<string.h>
    #include<string>
    #include<math.h>
    #include<map>
    #include<set>
    #define ll long long
    using namespace std;
    multiset<ll>p;
    string s,ss;
    int n,k;
    ll x;
    int main()
    {
        char c;
        while(cin>>n>>k)
        {
            p.clear();
            for(int i=0;i<n;i++)
            {
                cin>>c;
                if(c=='I')
                {
                    cin>>x;
                    p.insert(x);
                    if(p.size()>k)
                        p.erase(p.begin());
                }
                else
                {
                    multiset<ll>::iterator it;
                    it=p.begin();
                    cout<<*it<<endl;
                }
            }
        }
        return 0;
    
    }
  • 相关阅读:
    SV——override
    SV——声明和例化
    SV——automatic
    SV——类型转换$cast
    C++——局部变量、全局变量、静态变量与动态对象的性质(转载)
    C++——动态分配内存
    异步复位,同步释放(转)
    异步复位中的recovery time和removal time(转)
    UVM——virtual sequencer和virtual sequence
    软件工程 实践者的研究方法 第38章答案
  • 原文地址:https://www.cnblogs.com/-citywall123/p/11241376.html
Copyright © 2020-2023  润新知