• hdu 1004 Let the Balloon Rise


    Let the Balloon Rise

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 165255    Accepted Submission(s): 65779


    Problem Description
    Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

    This year, they decide to leave this lovely job to you. 
     
    Input
    Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

    A test case with N = 0 terminates the input and this test case is not to be processed.
     
    Output
    For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
     
    Sample Input
    5
    green
    red
    blue
    red
    red
    3
    pink
    orange
    pink
    0
     
    Sample Output
    red
    pink
     
    题意:输出颜色出现次数最多的颜色
     
    #include<iostream>
    #include<string.h>
    #include<string>
    #include<algorithm>
    #include<math.h>
    #include<map>
    #include<set>
    using namespace std;
    map<string,int>m;
    string s;
    int main()
    {
      int n;
      while(cin>>n&&n)
      {
        int cnt,mx=0;
        m.clear();
        for(int i=0;i<n;i++)
        {
            cin>>s;
            if(m.count(s)==0)
                m[s]=1;
            else
                m[s]++;
            mx=max(mx,m[s]);
        }
        
        map<string,int>::iterator it;
        for(it=m.begin();it!=m.end();it++)
        {
          cnt=it->second;
          if(cnt==mx)
          {
              cout<<it->first<<endl;
              break;
          }
        }
      }
      
        return 0;
    }
  • 相关阅读:
    前端设计网站收藏
    JAVA的StringBuffer类
    JDBC连接数据库
    JSP中request属性的用法
    jquery学习
    servlet学习(一)
    javascript 计算器
    xml学习(一)
    网站之单点登录简单思路
    关于ASP.NET中Menu控件在浏览器中不正常显示解决方法
  • 原文地址:https://www.cnblogs.com/-citywall123/p/11238008.html
Copyright © 2020-2023  润新知