• poj 3262 Protecting the Flowers 贪心 牛吃花


    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 11402   Accepted: 4631

    Description

    Farmer John went to cut some wood and left N (2 ≤ N ≤ 100,000) cows eating the grass, as usual. When he returned, he found to his horror that the cluster of cows was in his garden eating his beautiful flowers. Wanting to minimize the subsequent damage, FJ decided to take immediate action and transport each cow back to its own barn.

    Each cow i is at a location that is Ti minutes (1 ≤ Ti ≤ 2,000,000) away from its own barn. Furthermore, while waiting for transport, she destroys Di (1 ≤ Di ≤ 100) flowers per minute. No matter how hard he tries, FJ can only transport one cow at a time back to her barn. Moving cow i to its barn requires 2 × Ti minutes (Ti to get there and Ti to return). FJ starts at the flower patch, transports the cow to its barn, and then walks back to the flowers, taking no extra time to get to the next cow that needs transport.

    Write a program to determine the order in which FJ should pick up the cows so that the total number of flowers destroyed is minimized.

    Input

    Line 1: A single integer N
    Lines 2..N+1: Each line contains two space-separated integers, Ti and Di, that describe a single cow's characteristics

    Output

    Line 1: A single integer that is the minimum number of destroyed flowers

    Sample Input

    6
    3 1
    2 5
    2 3
    3 2
    4 1
    1 6

    Sample Output

    86

    Hint

    FJ returns the cows in the following order: 6, 2, 3, 4, 1, 5. While he is transporting cow 6 to the barn, the others destroy 24 flowers; next he will take cow 2, losing 28 more of his beautiful flora. For the cows 3, 4, 1 he loses 16, 12, and 6 flowers respectively. When he picks cow 5 there are no more cows damaging the flowers, so the loss for that cow is zero. The total flowers lost this way is 24 + 28 + 16 + 12 + 6 = 86.
     
    题意:有 n 头牛在吃鲜花,给你每头牛赶回到牛圈需要的时间 t(往返需要的时间为2*t) 和这头牛每分钟吃花的数量 d ,问你如何将所有牛赶回牛圈,使损失的鲜花最少。
     
    题解:假设有A、B两头牛,A.t和A.d分别代表将牛赶回去的时间和损失话的数量。若先将牛A赶回去,损失的花为B.d*A.t*2 ;若先将牛B赶回去,损失花的数量为A.d*B.t*2;
    由此可以确定排序方式为  return  B.d*A.t*2  <  A.d*B.t*2;
     
    注意数据范围为long long,要预处理时间,避免超时
     
    #include<iostream>
    #include<algorithm>
    #define ll long long
    using namespace std;
    struct node
    {
        ll t;
        ll d;
        ll id;
    }p[100005];
    bool cmp(node a,node b)
    {
        return a.t*b.d<a.d*b.t;
    }
    ll sum[100005];
    int main()
    {
        ll n;
        cin>>n;
        for(int i=1;i<=n;i++)
        {
            cin>>p[i].t>>p[i].d;
            p[i].id=i;
        }
        sort(p+1,p+1+n,cmp);
        ll ans=0;
        sum[1]=0;
        for(int i=2;i<=n;i++)//预处理,防止超时
            sum[i]=sum[i-1]+p[i-1].t*2;
        
        for(int i=2;i<=n;i++)
            ans=ans+p[i].d*sum[i];
        
        cout<<ans<<endl;
        return 0;
    }
  • 相关阅读:
    2月3日
    照片测试
    家属签证计时
    我来了
    090204 阴天
    重要提醒to 小爱
    小毛小毛
    C++Primer学习日程
    资料库字段存储文件记录的方式
    本日有点忙
  • 原文地址:https://www.cnblogs.com/-citywall123/p/11184901.html
Copyright © 2020-2023  润新知