• hdu-1702-栈和队列


    ACboy needs your help again!

    Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 12994    Accepted Submission(s): 6407


    Problem Description
    ACboy was kidnapped!! 
    he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(.
    As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can't solve my problems, you will die with ACboy."
    The problems of the monster is shown on the wall:
    Each problem's first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out").
    and the following N lines, each line is "IN M" or "OUT", (M represent a integer).
    and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!
     
    Input
    The input contains multiple test cases.
    The first line has one integer,represent the number oftest cases.
    And the input of each subproblem are described above.
     
    Output
    For each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don't have any integer.
     
    Sample Input
    4 4 FIFO IN 1 IN 2 OUT OUT 4 FILO IN 1 IN 2 OUT OUT 5 FIFO IN 1 IN 2 OUT OUT OUT 5 FILO IN 1 IN 2 OUT IN 3 OUT
     
    Sample Output
    1 2 2 1 1 2 None 2 3
    #include<iostream>
    #include<string.h>
    #include<queue>
    #include<stack>
    using namespace std;
    queue<int>a;
    stack<int>b;
    int main()
    {
      int n,t,x;
      char str[5],s[5];
      cin>>n;
      while(n--)
      {
        cin>>t>>str;
        if(strcmp(str,"FIFO")==0)
        {
          for(int i=0;i<t;i++)
          {
            cin>>s;
            if(strcmp(s,"IN")==0)
            {
              cin>>x;
              a.push(x);
            }
            else
            {
              if(a.empty())
                cout<<"None"<<endl;
              else
              {
                cout<<a.front()<<endl;
                a.pop();
              }
            }
          }
          while(!a.empty())
            a.pop();
        }
        else
        {
          for(int i=0;i<t;i++)
          {
            cin>>s;
            if(strcmp(s,"IN")==0)
            {
              cin>>x;
              b.push(x);
            } 
            else
            {
              if(b.empty())
                cout<<"None"<<endl;
              else
              {
                cout<<b.top()<<endl;
                b.pop();
              }
            }
          }
          while(!b.empty())
                b.pop();
        }
      }
    
      return 0;
    }
  • 相关阅读:
    递归判断回文
    从小工到专家阅读笔记1
    建立SQL全文索引提升搜索速度
    数据库SQLServer经验小记
    [转]C#中调用SQL存储过程(带输入输出参数的例子)
    20101124 14:55 全文索引是解决海量数据模糊查询的较好解决办法
    使用SQL Server 2008提供的表分区向导
    千万级SQL Server数据库表分区的实现
    C#调用存储过程简单完整例子
    SQL server 海量数据库的查询优化及分页算法(收藏)
  • 原文地址:https://www.cnblogs.com/-citywall123/p/10540393.html
Copyright © 2020-2023  润新知