• poj1384——dp,完全背包


    POJ 1384  dp,完全背包

    Piggy-Bank
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 8404   Accepted: 4082

    Description

    Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid. 

    But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs! 

    Input

    The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.

    Output

    Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".

    Sample Input

    3
    10 110
    2
    1 1
    30 50
    10 110
    2
    1 1
    50 30
    1 6
    2
    10 3
    20 4

    Sample Output

    The minimum amount of money in the piggy-bank is 60.
    The minimum amount of money in the piggy-bank is 100.
    This is impossible.

    题意:用一堆给定面值的硬币a1,a2,...,aN,(ai和aj的面值可以相同),组合成恰好质量为W的最小总面值
    思路:dp,设选择范围为前i个硬币组成质量恰好为j的最小面值为dp(j)=max(dp(j),dp(j-w[i])+p[i]),(j>=w[i])
    由于罐里每种硬币可以有多个(即完全背包模型),因此j从0开始遍历这样dp[i][j]可以从d[i-1][j-w[i]]中得到更新,也可以从dp[i][j-w[i]]中更新,正好符合每种物体可以取无穷多个,注意不能用二维数组或滚动数组,否则dp[i][j]只能从dp[i-1][j-w[i]]中得到更新,而不能从dp[i][j-w[i]]更新,不符合dp[i][j]的前一个状态是dp[i][j-w[i]],就变成01背包了,而不是完全背包
    边界:dp(j)=dp(j)(j>=w[i]),dp(0)=0(总质量为0,总面值肯定为0),初始化dp={INF},INF即总面值无限大,即没有合适的匹配方案;

    C++代码:
    //poj1384  dp
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    #include<ctype.h>
    
    using namespace std;
    
    const int maxn=510;
    const int INF=1000100;
    int T;
    int E,F;
    int N;
    int p[maxn],w[maxn];
    int dp[INF];
    
    int main()
    {
        cin>>T;
        while(T--){
            cin>>E>>F>>N;
            for(int i=1;i<=N;i++){
                cin>>p[i]>>w[i];
            }
            for(int i=0;i<=F-E;i++) dp[i]=INF;
            dp[0]=0;
            for(int i=1;i<=N;i++){
                for(int j=w[i];j<=F-E;j++){
                        dp[j]=min(dp[j-w[i]]+p[i],dp[j]);
                }
            }
            if(dp[F-E]!=INF) cout<<"The minimum amount of money in the piggy-bank is "<<dp[F-E]<<"."<<endl;
            else cout<<"This is impossible."<<endl;
        }
        return 0;
    }
    dp_完全背包

      Java代码:

    //594ms
    import java.util.*;
    import java.io.*;
    
    public class Main {
        static final int maxn=510;
        static final int INF=1000100;
        public static int min(int a,int b){
            return a<b?a:b;
        }
        public static void main(String[] args){
            Scanner in=new Scanner(System.in);
            int T=in.nextInt();
            while(T--!=0){
                int E=in.nextInt();
                int F=in.nextInt();
                int N=in.nextInt();
                int p[]=new int[N+1],w[]=new int[N+1];
                for(int i=1;i<=N;i++){
                    p[i]=in.nextInt();
                    w[i]=in.nextInt();
                }
                int dp[]=new int[F-E+1];
                for(int i=0;i<=F-E;i++) dp[i]=INF;
                dp[0]=0;
                for(int i=1;i<=N;i++){
                    for(int j=w[i];j<=F-E;j++){
                        dp[j]=min(dp[j-w[i]]+p[i],dp[j]);
                    }
                }
                if(dp[F-E]!=INF) System.out.println("The minimum amount of money in the piggy-bank is "+dp[F-E]+".");
                else System.out.println("This is impossible.");
            }
        }
    }
    dp——java
    
    
    没有AC不了的题,只有不努力的ACMER!
  • 相关阅读:
    Mybatis学习随笔3
    Mybatis学习随笔2
    Mybatis学习随笔
    Java校招面试-什么是线程安全/不安全
    装饰器2
    装饰器
    默认传参的陷阱
    处理日志文件
    第二天
    用户登录
  • 原文地址:https://www.cnblogs.com/--560/p/4345855.html
Copyright © 2020-2023  润新知