• poj1837——dp


    POJ 1837  dp

    Balance
    Time Limit: 1000MS   Memory Limit: 30000K
    Total Submissions: 11278   Accepted: 7017

    Description

    Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance. 
    It orders two arms of negligible weight and each arm's length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights. 
    Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced. 

    Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device. 
    It is guaranteed that will exist at least one solution for each test case at the evaluation. 

    Input

    The input has the following structure: 
    • the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20); 
    • the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: '-' for the left arm and '+' for the right arm); 
    • on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights' values. 

    Output

    The output contains the number M representing the number of possibilities to poise the balance.

    Sample Input

    2 4	
    -2 3 
    3 4 5 8
    

    Sample Output

    2
    题意:在天平挂上所有的砝码,问使天平平衡的方案总数
    思路:dp,首先定义平衡度:平衡时为0,倾向左为正,右为负,设挂完第i个砝码时平衡度为j的方案数为dp(i,j),
    则dp(i,j)=dp(i-1,j-w[i]*x[1])+dp(i-1,j-w[i]*x[2])+...+dp(i-1,j-w[i]*x[C]);
    边界限定:dp(0,0)=1; dp(0,j)=0 (j!=0)
    所求解: dp(G,0)

    记忆化搜索:
    //47ms
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    
    const int maxn=30;
    const int INF=15010;
    int C,G;//C means the sum of hooks, G means the sum of weights
    int x[maxn],w[maxn];
    int d[maxn][INF];
    int zero=INF/2;
    
    int dp(int i,int j)
    {
        int &ans=d[i][j];
        if(ans!=-1) return ans;
        if(i==0){
            if(j==zero) return ans=1;
            return ans=0;
        }
        int sum=0;
        for(int k=1;k<=C;k++) sum+=dp(i-1,j-w[i]*x[k]);
        return ans=sum;
    }
    
    int main()
    {
        while(cin>>C>>G){
            for(int i=1;i<=C;i++) cin>>x[i];
            for(int i=1;i<=G;i++) cin>>w[i];
            memset(d,-1,sizeof(d));
            cout<<dp(G,zero)<<endl;
        }
        return 0;
    }
    记忆化搜索

    递推:

    //110ms
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    
    const int maxn=30;
    const int INF=15010;
    const int zero=INF/2;
    
    int C,G;
    int w[maxn],x[maxn];
    int dp[maxn][INF];
    
    int main()
    {
        cin>>C>>G;
        for(int i=1;i<=C;i++) cin>>x[i];
        for(int i=1;i<=G;i++) cin>>w[i];
        memset(dp,0,sizeof(dp));
        for(int i=0;i<INF;i++) dp[0][i]=0;
        dp[0][zero]=1;
        for(int i=1;i<=G;i++){
            for(int j=0;j<INF;j++){
                for(int k=1;k<=C;k++){
                    dp[i][j]+=dp[i-1][j-w[i]*x[k]];
                }
            }
        }
        cout<<dp[G][zero]<<endl;
        return 0;
    }
    递推
    没有AC不了的题,只有不努力的ACMER!
  • 相关阅读:
    Spiral Matrix II
    N-Queens
    Jump Game II
    js改变div高度
    Jenkins + testNg + maven 项目持续集成
    bootstrap做的导航
    bootstrap左侧边栏
    WEB-INF下jsp跳转
    jsp页面无法解析EL表达式
    springMVC和mybatis整合,jsp对时间进行格式化
  • 原文地址:https://www.cnblogs.com/--560/p/4341385.html
Copyright © 2020-2023  润新知