• 我的第一道java_A+B


    JAVA——A+B

    ——————我的第一道JAVA

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 241566    Accepted Submission(s): 46567


    Problem Description
    I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
     
    Input
    The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
     
    Output
    For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
     
    Sample Input
    2 1 2 112233445566778899 998877665544332211
     
    Sample Output
    Case 1:
    1 + 2 = 3
    Case 2:
    112233445566778899 + 998877665544332211 = 1111111111111111110
     
     大数题,我的第一道JAVA
     
    import java.util.Scanner;
    import java.math.BigInteger;
    
    public class Main {
        final int maxn=1000100;
        public static void main(String[] args){
            Scanner in=new Scanner(System.in);
            int T;
            T=in.nextInt();
            for(int i=1;i<=T;i++){
                BigInteger a,b,c;
                a=in.nextBigInteger();
                b=in.nextBigInteger();
                c=a.add(b);
                System.out.println("Case "+i+":");
                System.out.println(a.toString()+" + "+b.toString()+" = "+c.toString());
                if(i<T) System.out.println();
            }
        }
    }
    A+B
     
    没有AC不了的题,只有不努力的ACMER!
  • 相关阅读:
    Dockerize a .NET Core application
    Images之管理image
    Images之Dockerfile中的命令2
    Images之Dockerfile中的命令1
    Docker Builders:Builder pattern vs. Multi-stage builds in Docker
    Images之multi-stage builds
    Images之base image
    Images之Dockerfiles
    Docker 开发最佳实践
    Docker 开发概述
  • 原文地址:https://www.cnblogs.com/--560/p/4339871.html
Copyright © 2020-2023  润新知