• 28-Truck History(poj1789最小生成树)


                                             Truck History
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 32474   Accepted: 12626

    Description

    Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on. 

    Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as 
    1/Σ(to,td)d(to,td)

    where the sum goes over all pairs of types in the derivation plan such that to is the original type and td the type derived from it and d(to,td) is the distance of the types. 
    Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan. 

    Input

    The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

    Output

    For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

    Sample Input

    4
    aaaaaaa
    baaaaaa
    abaaaaa
    aabaaaa
    0
    

    Sample Output

    The highest possible quality is 1/3.
    

    Source

    思路:题意是要在找一个最先版本,其余版本有其逐步演化而来,每次演化的消耗为不同字母的个数,所以题意可以转化为,将n个字符串看作n个节点,使得这n个节点是联通的,并且之间的距离是最短之和最小,而两个节点间的距离就是不同的字母个数,所以直接转为了最小生成树的问题。
    ps: poj不支持string cat[2005][2005], cin >> cat[i]这种???
     
    #include <iostream>
    #include <cstring>
    using namespace std;
    char car[2005][8];
    int mp[2005][2005];
    
    int prim(int n){
    	int dis[2005], visit[2005] = {0};
    	memset(dis, 0x3f, sizeof(dis));
    	dis[0] = 0;
    	visit[0] = 1;
    	for(int i = 1; i < n; i++){
    		dis[i] = mp[i][0];
    	}
    	for(int i = 0; i < n - 1; i++){
    		int min = 0x3f3f3f3f;
    		int p = -1;
    		for(int j = 1; j < n; j++){
    			if(visit[j] == 0 && min > dis[j]){
    				min = dis[j];
    				p = j;
    			}
    		}
    		if(p == -1){
    			return -1; //不连通 
    		}
    		visit[p] = 1;
    		for(int i = 1; i < n; i++){
    			if(visit[i] == 0 && dis[i] > mp[p][i]){
    				dis[i] = mp[p][i];
    			}
    		}
    	}
    	int sum = 0;
    	for(int i = 0; i < n; i++)
    		sum += dis[i];
    	return sum;
    }
    
    int main(){
    //	std::ios::sync_with_stdio(false);
    	int n;
    	while(cin >> n && n){
    		memset(mp, 0x3f, sizeof(mp));
    		for(int i = 0; i < n; i++){
    			cin >> car[i];
    			int sum = 0;
    			for(int j = 0; j < i; j++){
    				sum = 0;
    				for(int k = 0; k < 7; k++){
    					if(car[j][k] != car[i][k]){
    						sum++;
    					}
    				}
    				mp[i][j] = mp[j][i] = sum;
    			}
    		}
    		int rt = prim(n);
    		cout << "The highest possible quality is 1/";
    		cout << rt;
    		cout << "." << endl;
    	}
    	return 0;
    }
    

      

  • 相关阅读:
    Winfrom 动画实现
    Android-SD卡相关操作
    Android-动态权限获取
    Java 常用知识点
    无锁队列的实现
    稳定的快排
    设计模式
    map的线程安全
    win 消息
    memecpy源码
  • 原文地址:https://www.cnblogs.com/zhumengdexiaobai/p/9318405.html
Copyright © 2020-2023  润新知