• 1008 数组元素循环右移问题 (20)(20 分)


    1008 数组元素循环右移问题 (20)(20 分)

    一个数组A中存有N(N&gt0)个整数,在不允许使用另外数组的前提下,将每个整数循环向右移M(M>=0)个位置,即将A中的数据由(A~0~ A~1~……A~N-1~)变换为(A~N-M~ …… A~N-1~ A~0~ A~1~……A~N-M-1~)(最后M个数循环移至最前面的M个位置)。如果需要考虑程序移动数据的次数尽量少,要如何设计移动的方法?

    输入格式:每个输入包含一个测试用例,第1行输入N ( 1<=N<=100)、M(M>=0);第2行输入N个整数,之间用空格分隔。

    输出格式:在一行中输出循环右移M位以后的整数序列,之间用空格分隔,序列结尾不能有多余空格。

    输入样例:

    6 2
    1 2 3 4 5 6
    

    输出样例:

    5 6 1 2 3 4
    #include <iostream>
    #include <algorithm>
    
    using namespace std ; 
    
    #define maxn 105
    int n , m ; 
    int num[maxn] ; 
    
    int main(){
        int n , m ; 
        cin >> n >> m ; 
        for(int i=0 ; i<n ; i++){
            cin >> num[(i+m)%n] ;
        }
    
        for(int i=0 ; i<n ; i++){
            if(i == 0){
                cout << num[i] ; 
            }else {
                cout << " " << num[i] ; 
            }
        }
        cout << endl ; 
    }
  • 相关阅读:
    poj2181 jumping cow
    poj2184
    POJ 1189 钉子和小球
    uva11019矩阵匹配器D316
    noip2015运输计划
    [LintCode] Last Position of Target
    [LintCode] K Closest Points
    [LintCode] K Closest Numbers In Sorted Array
    [LintCode] Closest Number in Sorted Array
    [LintCode] Perfect Squares
  • 原文地址:https://www.cnblogs.com/yi-ye-zhi-qiu/p/9107821.html
Copyright © 2020-2023  润新知