• 【ACM】poj_1363_Rails_201308081502


    Rails
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 21528   Accepted: 8597

    Description

    There is a famous railway station in PopPush City. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish only a surface track. Moreover, it turned out that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track.

    The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has N <= 1000 coaches numbered in increasing order 1, 2, ..., N. The chief for train reorganizations must know whether it is possible to marshal coaches continuing in the direction B so that their order will be a1, a2, ..., aN. Help him and write a program that decides whether it is possible to get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at any time there can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station.

    Input

    The input consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integer N described above. In each of the next lines of the block there is a permutation of 1, 2, ..., N. The last line of the block contains just 0.

    The last block consists of just one line containing 0.

    Output

    The output contains the lines corresponding to the lines with permutations in the input. A line of the output contains Yes if it is possible to marshal the coaches in the order required on the corresponding line of the input. Otherwise it contains No. In addition, there is one empty line after the lines corresponding to one block of the input. There is no line in the output corresponding to the last ``null'' block of the input.

    Sample Input

    5
    1 2 3 4 5
    5 4 1 2 3
    0
    6
    6 5 4 3 2 1
    0
    0

    Sample Output

    Yes
    No
    
    Yes
    

    Source

     
     

    #include <stdio.h>
    #include <string.h>

    int a[1100];
    int b[1100];

    int main()
    {
        int i,j,n,top;
        while(scanf("%d",&n),n)
        {
            memset(a,0,sizeof(a));
            while(scanf("%d",&a[1]),a[1])
            {          
                memset(b,0,sizeof(b));
                for(i=2;i<=n;i++)
                scanf("%d",&a[i]);
                j=top=1;
                for(i=1;i<=n;i++)
                {
                    b[top++]=i;  //进栈
                    while(j<=n&&b[top-1]==a[j])
                    {
                        --top;   //如果符合条件 出栈
                        j++;
                    }              
                }
                if(top==1)      //栈为空
                printf("Yes ");
                else
                printf("No ");           
            }
            printf(" ");
        }
        return 0;
    }

    //栈的简单应用

  • 相关阅读:
    Topshelf的使用
    ref和out的区别
    .NET编码解码(HtmlEncode与HtmlDecode)
    查询表中某字段有重复记录个数的方法
    ActiveReports 报表应用教程 (8)---交互式报表之动态过滤
    ActiveReports 报表应用教程 (7)---交叉报表及数据透视图实现方案
    ActiveReports 报表应用教程 (6)---分组报表
    ActiveReports 报表应用教程 (5)---解密电子商务领域首张电子发票的诞生(套打报表)
    ActiveReports 报表应用教程 (4)---分栏报表
    ActiveReports 9 新功能:借助目录(TOC)控件为报表添加目录功能
  • 原文地址:https://www.cnblogs.com/xl1027515989/p/3246088.html
Copyright © 2020-2023  润新知