• HDU3746——Cyclic Nacklace(Next数组求最小循环节)


    CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of “HDU CakeMan”, he wants to sell some little things to make money. Of course, this is not an easy task.

    As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl’s fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls’ lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet’s cycle is 9 and its cyclic count is 2:

    这里写图片描述

    Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
    CC is satisfied with his ideas and ask you for help.
    Input

    The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
    Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by ‘a’ ~’z’ characters. The length of the string Len: ( 3 <= Len <= 100000 ).
    Output

    For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.
    Sample Input

    3
    aaa
    abca
    abcde
    

    Sample Output

    0
    2
    5
    

    思路:
    next数组求最小循环节原理(此处转载自http://blog.csdn.net/reverie_mjp):
    这里写图片描述
    假设图中的黑色是原来的字符串,现在要求最小循环节,对于nxt[len]来说指的是图中蓝色和黄色的长度,而且蓝色和黄色是相等的,

    那么绿色和紫色也是相等的,,对比原串可知紫色跟粉色是相同的子串,那么绿色跟粉色相同,然后对比蓝色跟黄色可知红色跟粉色相同,对比原串,红色跟棕色相同,那么棕色跟粉色相同,不断重复此过程可知若此字符串有最小循环节,那么循环次数一定为len/(len-nxt[len])。

    结论:如果len%(len-nxt[len])=0,那么循环次数为len/(len-nxt[len]),否则为1

    明白了以上原理后我们知道只要求得整个字符串的前缀和后缀的最大公共长度就可以得出结果。而这正是Next的作用。
    另外这里推荐Next数组写法使用非优化版本
    即:

    void getNext()
    {
        memset(Next, 0, sizeof(Next));
        int i = -1;
        int j = 0;
        int len = strlen(p);
        Next[0] = -1;
        while (j < len)
        {
            if (i == -1 || p[i] == p[j])
            {
                Next[++j] = ++i;
            }
            else i = Next[i];
        }
    }

    优化版本:

    void getNext()
    {
        memset(Next, 0, sizeof(Next));
        int i = -1;
        int j = 0;
        int len = strlen(p);
        Next[0] = -1;
        while (j < len)
        {
            if (i == -1 || p[i] == p[j])
            {
                if (p[i + 1] == p[j + 1])Next[++j] = Next[++i];
                else Next[++j] = ++i;
            }
            else i = Next[i];
        }
    }

    一般来说KMP匹配字符串时使用优化版本,求前后缀最大公共长时使用非优化版本。

    代码:

    #include <iostream>
    #include <cstdio>
    #include <cstring>
    
    using namespace std;
    
    #define MAXN 100005
    
    int Next[MAXN];
    char p[MAXN];
    
    void getNext()
    {
        memset(Next, 0, sizeof(Next));
        int i = -1;
        int j = 0;
        int len = strlen(p);
        Next[0] = -1;
        while (j < len)
        {
            if (i == -1 || p[i] == p[j])
            {
                Next[++j] = ++i;
            }
            else i = Next[i];
        }
    }
    
    int main()
    {
        ios::sync_with_stdio(false);
        int N;
        cin >> N;
        while (N--)
        {
            cin >> p;
            getNext();
            int len = strlen(p);
            int sum = len - Next[len];
            if (Next[len] == 0)cout << len << endl;
            else if (len % sum == 0)cout << 0 << endl;
            else cout << sum - len % sum << endl;
        }
    
        return 0;
    }
  • 相关阅读:
    【剑指offer】数字在排序数组中出现的次数
    移动互联网的架构设计浅谈一
    Android开发中遇到的adb问题解决方法
    Datagrid分页、排序、删除代码
    新辰:关于个人站点安全问题的分析及对策探讨
    Android开发中,activity页面跳转后是空白
    实战——二、c#窗体(2)
    实战——一、c#窗体(1)
    c#的sealed修饰符
    c#中,类的重写中,new和override的区别
  • 原文地址:https://www.cnblogs.com/vocaloid01/p/9514172.html
Copyright © 2020-2023  润新知