• UVALive5520 UVA305 POJ1012 HDU1443 Joseph【数学计算+打表】


    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 54650   Accepted: 20912

    Description

    The Joseph's problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved. 

    Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy. 

    Input

    The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.

    Output

    The output file will consist of separate lines containing m corresponding to k in the input file.

    Sample Input

    3
    4
    0
    

    Sample Output

    5
    30
    
    

    Source


    Regionals 1995 >> Europe - Central


    问题链接UVALive5520 UVA305 POJ1012 HDU1443 Joseph

    问题简述:(略)

    问题分析(略)

    程序说明:占个位置,以后说明。

    题记:(略)


    参考链接:(略)


    AC的C++语言程序如下:

    /* UVALive5520 UVA305 POJ1012 HDU1443 Joseph */
    
    #include <iostream>
    
    using namespace std;
    
    const int N = 14;
    int Joseph[N];
    
    bool f(int k, int m)
    {
        int n, s;
        n = 2 * k;
        s = 0;
        for(int i=0; i<k; i++) {
            s = (s + m - 1) % (n - i);
            if(s < k)
                return false;
        }
        return true;
    }
    
    void maketable(int k)
    {
        int j;
        for(int i=1; i<=k; i++) {
            j = i + 1;
            for(;;) {
                if(f(i, j)) {           // t(k+1)
                    Joseph[i] = j;
                    break;
                }
                else if(f(i, j + 1)) {  // t(k+1)+1
                    Joseph[i] = j + 1;
                    break;
                }
                j += i + 1;
            }
        }
    }
    
    int main()
    {
        maketable(N);
    
        int k;
        while(cin >> k && k) {
            cout << Joseph[k] << endl;
        }
    
        return 0;
    }


  • 相关阅读:
    JSP原理
    基于Servlet+JSP+JavaBean开发模式的用户登录注册
    Eclipse-Java EE
    Javaweb经典三层架构的演变
    Tomcat9 访问 Manager App
    Tomcat 访问 Manager App,Host Manager
    phantomjs 抓取房产信息
    phantomjs 无法打开https网站解决方案
    java HashMap,LinkedHashMap,TreeMap应用
    tomcat 部署 RESTful 服务实例
  • 原文地址:https://www.cnblogs.com/tigerisland/p/7563555.html
Copyright © 2020-2023  润新知