• HDU1258 Sum It Up(DFS)


    Sum It Up

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
    Total Submission(s) : 22   Accepted Submission(s) : 17

    Font: Times New Roman | Verdana | Georgia

    Font Size: ← →

    Problem Description

    Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t=4, n=6, and the list is [4,3,2,2,1,1], then there are four different sums that equal 4: 4,3+1,2+2, and 2+1+1.(A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.

    Input

    The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x1,...,xn. If n=0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12(inclusive), and x1,...,xn will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.

    Output

    For each test case, first output a line containing 'Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line 'NONE'. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distince; the same sum connot appear twice.

    Sample Input

    4 6 4 3 2 2 1 1
    5 3 2 1 1
    400 12 50 50 50 50 50 50 25 25 25 25 25 25
    0 0
    

    Sample Output

    Sums of 4:
    4
    3+1
    2+2
    2+1+1
    Sums of 5:
    NONE
    Sums of 400:
    50+50+50+50+50+50+25+25+25+25
    50+50+50+50+50+25+25+25+25+25+25
    

    Source

    浙江工业大学第四届大学生程序设计竞赛

    #include <iostream>
    #include<cstring>
    #include<cstdio>
    #include<algorithm>
    using namespace std;
    int i,j,n,t,flag,l,x;
    int a[105],b[105],f[105];
    int cmp(int a,int b)
    {
        return a>b;
    }
    void dfs(int sum,int k)
    {
        if (sum==t)
        {
          int m;
          flag=1;
          for(int i=l;i>0;i--)
          if (b[i]>0){b[i]--; m=a[i]; break;}
              for(int i=1;i<=l;i++)
              {
                   for(int j=1;j<=b[i];j++)
                      printf("%d+",a[i]);
              }
         printf("%d\n",m);
         return;
        }
        if(k>l) return;
        for(int j=f[a[k]];j>0;j--)
         if (sum+j*a[k]<=t)
            {
                 b[k]=j;
                 dfs(sum+j*a[k],k+1);
                 b[k]=0;
            }
          dfs(sum,k+1);
        return;
    }
    int main()
    {
        while(~scanf("%d%d",&t,&n))
        {
            if(t==0 && n==0) break;
            printf("Sums of %d:\n",t);
            memset(f,0,sizeof(f));
            l=0;
            for(i=1;i<=n;i++)
            {
                scanf("%d",&x);
                if(!f[x]) a[++l]=x;
                f[x]++;
            }
            sort(a+1,a+l+1,cmp);
            flag=0;
            dfs(0,1);
            if (!flag) printf("NONE\n");
        }
        return 0;
    }
  • 相关阅读:
    网口
    uart
    wwww
    ddr相关的配置经验
    嵌入式的指令集和寄存器
    协议栈
    《贝贝GO》服务条款
    《贝贝GO》隐私政策
    《贝贝GO》技术支持
    《王牌助理》隐私政策
  • 原文地址:https://www.cnblogs.com/stepping/p/5667481.html
Copyright © 2020-2023  润新知