• [ACM] poj 1146 ID Codes(字符串的下一个排列)


    Description

    It is 2084 and the year of Big Brother has finally arrived, albeit a century late. In order to exercise greater control over its citizens and thereby to counter a chronic breakdown in law and order, the Government decides on a radical measure--all citizens are to have a tiny microcomputer surgically implanted in their left wrists. This computer will contains all sorts of personal information as well as a transmitter which will allow people's movements to be logged and monitored by a central computer. (A desirable side effect of this process is that it will shorten the dole queue for plastic surgeons.)

    An essential component of each computer will be a unique identification code, consisting of up to 50 characters drawn from the 26 lower case letters. The set of characters for any given code is chosen somewhat haphazardly. The complicated way in which the code is imprinted into the chip makes it much easier for the manufacturer to produce codes which are rearrangements of other codes than to produce new codes with a different selection of letters. Thus, once a set of letters has been chosen all possible codes derivable from it are used before changing the set.

    For example, suppose it is decided that a code will contain exactly 3 occurrences of `a', 2 of `b' and 1 of `c', then three of the allowable 60 codes under these conditions are:
          abaabc
    
          abaacb
    
          ababac
    
    

    These three codes are listed from top to bottom in alphabetic order. Among all codes generated with this set of characters, these codes appear consecutively in this order.

    Write a program to assist in the issuing of these identification codes. Your program will accept a sequence of no more than 50 lower case letters (which may contain repeated characters) and print the successor code if one exists or the message `No Successor' if the given code is the last in the sequence for that set of characters.

    Input

    Input will consist of a series of lines each containing a string representing a code. The entire file will be terminated by a line consisting of a single #.

    Output

    Output will consist of one line for each code read containing the successor code or the words 'No Successor'.

    Sample Input

    abaacb
    cbbaa
    #

    Sample Output

    ababac
    No Successor

    Source

    思路:

    采用了next_permutation(a,a+len);这一函数。

    代码:

    #include <iostream>
    #include <string.h>
    #include <algorithm>
    using namespace std;
    char a[52],b[52];
    
    int main()
    {
        while(cin>>a&&a[0]!='#')
        {
            int len=strlen(a);
            next_permutation(a,a+len);
            strcpy(b,a);
            sort(b,b+len);
            int flag=0;
            for(int i=0;i<len;i++)
                if(a[i]!=b[i])
                flag=1;
            if(flag==0)
                cout<<"No Successor"<<endl;
            else
                cout<<a<<endl;
    
        }
        return 0;
    }
    


     

  • 相关阅读:
    谈谈关于MVP模式中V-P交互问题
    Delphi MVC模 2
    Delphi MVC模式 1
    Java长整除问题
    Java中Scanner类的简单用法
    Java中throw和throws的区别
    Java必须掌握的运算符
    Java编程多重循环
    Java实现三种简单的排序
    使用Java向properties存数据
  • 原文地址:https://www.cnblogs.com/sr1993/p/3697765.html
Copyright © 2020-2023  润新知